Fontaswesome not so awesome...

I'm having trouble isolating the problem, but on this website I have four icons that are not showing up since I added a few WPMUDev plugins. The first two are in the menu, and should be a facebook icon and a twitter icon. The second two are on the contact page, and should be a phone and an envelope. These draw their icons from fontawesome. I'm hoping to get some help isolating the conflict and correcting the issue.

Thanks!

    Danny

    I don't think you will find any support with wpmudev because they are only interested in scamming you out of money and making unauthorized charges to your card. I have tried to cancel. They tell you a bunch of BS and that it's easy "don't worry you can cancel any time with 1 click" and yet here we are 20 e-mails later, support ticket after support tick, no cancel button in the dashboard and despite having spent weeks saying I want to cancel this damn account they charged me anyway!
    I would recommend you leave wpmudev as soon as you CAN!

    Justin

    Danny,

    I hate to hear about your experience. I totally understand about wanting to be the squeaky wheel. I haven't been here very long, but so far I have been thrilled with the support that I have received, and about half of it has come from fellow developers in this community. I hope you find what you are looking for. In the meantime, if you have any helpful tips for my icon problem that would be appreciated.

    Onward & Upward...

    Timothy Bowers

    Hey Danny

    Jumping on other members tickets really will not help the situation, but as you wish this to be public, fine. Firstly, there hasn't been 20 emails at all, there was one prior to today and this was our response on the 28th Feb, 2017:

    https://monosnap.com/file/COWNkXKB9ZYmauwXBXptkq9Q8ITv8k

    We gave you simple instruction on how to cancel your account, you failed to follow that and have only just followed up today. Instead of continuing to communicate with us you instead have tried to disturb and ruin the experience for our other members, that's not professional and most certainly isn't acceptable. I've removed your posting privileges as a result, happy to reinstate later once we've resolved this matter.

    I note you responded to our email today thus confirming you had instruction on how to cancel your account, you chose not to before renewal. You also sent another through our contact form.

    We'll continue to follow up through email with you.

    Justin I'm really sorry you've had to experience this today.

    Good to see you're having a great experience and are thrilled with our community and support so far.

    I'll have someone follow up shortly in regards to your original ticket.

    Denitsa

    Hello Justin,
    I hope you're having a beautiful day!

    You'd need to add some custom CSS to your page, which you can do either via a child theme's style.css file, or by using a plugin like SImple Custom CSS (found here https://wordpress.org/plugins/simple-custom-css/).

    When you install and activate the plugin, it creates a submenu under Appearance -> Custom CSS. There in the text box you need to paste the below code snippets and hit Update Custom CSS.

    For the links in the menu, it seems you're adding the header with Hustle, so a default font is given to the contents, overriding the Font Awesome.

    So, adding the following CSS should fix the menu:

    .icon-twitter:before {
        font-family: FontAwesome !important;
    }
    .icon-facebook:before {
        font-family: FontAwesome !important;
    }

    Strangely, on your Contacts page the two icons that are not showing properly lack the "fa fa-something" class, which is causing the issue, since it means they don't use the Font Awesome, instead, they have the fi-something class, which implies the Foundation Icons are being used here instead.

    As a quick fix, you might use the following CSS:

    .fi-mail:before {
        content: "\f0e0";
        font-family: FontAwesome;
    }
    
    .fi-telephone:before {
        content: "\f095";
        font-family: FontAwesome;
    }

    How have you been editing your theme, do you remember when you've changed those two? This could tell us why only those two got the Foundation Icons font and no the Font Awesome.

    If you're not happy with these icons, here (http://astronautweb.co/snippet/font-awesome/) you can find a list of all the Font Awesome icons. To change the ones displayed, you need to change the value next to content on the above CSS snippet with the one from the page with the icon codes I provided.

    If you have any additional issues, please let us know and we'll be happy to help!

    Have a nice day!

    Cheers,
    Denitsa