Footer Content Not Appearing Properly

The regular “Footer Content” Plugin (Appearance –> Footer Content) is not showing up properly with Courses pro. The text in the footers appear overlayed on each other, and no matter what I do (inserting additional “div” or “P” classes) it still appears overlayed. How to fix? Is there some CSS that I should use to resolve this? If so, please provide.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, F. Zaria!

    Happy Saturday!

    I would love to help, would you mind linking us to a page where we can see this error happening? That’ll make it easier to give you the correct CSS to help fix it.

    Did the footer content plugin come with your theme, or did you download it separately? I’d love to test with it, if you can let me know where you found it.

    Thanks!

  • FZCU
    • The Incredible Code Injector

    Ari:

    Hi, I just sent you a private message through the “Contact Us” form with the link that you requested. I am not allowed to post it publicly, as that section of our site officially does not exist yet.

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hi @f. Zaria,

    Thanks for the link to your page.

    I just checked in and found that a single line of css will make this done.

    footer { height: auto; }

    Now, I’m not sure if you knew where to add this line of code.

    So, as a quick note; there’s two ways we recommend you to go with:

    -> If you have already created child theme then place this line of code in the child theme’s style.css.

    -> or else, add this plugin https://wordpress.org/plugins/simple-custom-css/, to include your custom css codes.

    Let us know, if this helped you to resolve your issue.

    Regards,

    Sumit

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hello again, @f. Zaria,

    I’m glad that it worked the way you asked.

    For your another query, I checked it and will need to brief you how its showing up there.

    Since you already termed as “hyperlinked words” (we call them as ‘a’ tag in html), so there’s the theme’s default styling for hyperlinked words to have left and right padding as 10px.

    Now if you don’t want that much of spacing in this case, then you again have to overwrite the css (like done earlier with “footer”:wink: to make it look better.

    Here’s the code for that:

    .footer-navigation a { padding: 0px 0px 0px 10px; }

    You are already aware of where to place such codes, right!

    Happy coding, and get your site as you need it. :wink:

    Let us know, if you have any further queries for your project.

    Regards,

    Sumit

  • Sumit Kumar
    • Site Builder, Child of Zeus

    @f. Zaria

    Hello again, Sorry that you find trouble in implementing that code.

    The css is just enough to make it done for what you requested. When I just checked for that section in browser, I just couldn’t find the code that you placed in. The placement of the code really matters and it should overwrite the default css.

    I assume the code didn’t overwrite the default and so modifying the code I gave earlier,

    .footer-navigation a { padding: 0px 0px 0px 10px !important; }

    would make it fixed.

    But, if this doesn’t work again then its most likely that the placement is not in right place. If you please enable support access from WPMU DEV > Support then I can check it for you :slight_smile:

    Hope, this would make it easy for you to solve your issue.

    Regards,

    Sumit

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hello Zaria,

    Well Well Well, there’s complete misunderstanding with where I was looking at and where you were pointing the issue for! In the supported links, we see the link was for one your network site.

    Thanks, for making it clear in your earlier reply.

    Now, when I checked it in your main domain, (with the access you provided), it was something different there. You could check that part of code that I replaced with the new one in your Edit CSS window.

    #footer a { margin-right: 10px; }

    (You can decrease/increase this ‘px’ to your need and the spacing you want.)

    Further, If you want this work in your “course” theme, then please use the code that I gave you earlier and which you said was not working.

    Thanks a bunch for letting us in and to look in through to your site.

    Hope this is what you were waiting for the fix.

    Let us know, if you need any further assistance anywhere.

    Regards,

    Sumit

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hello @f. Zaria,

    First off, Please accept my apology for posting that link there. I was just pointing you where I was fixing the problem for and then you mentioned its different site. Removed the screenshot as well, :slight_smile:

    For your css issue, if you check your main site, you surely find the spacing between words is changed from before and I already mentioned that you can make this pixel value from code above to “0px” to see how much spacing you need within words.

    #footer a { margin-right: 0px; }

    But, if you need the css for some other site/network then you can let me know with screenshot and if possible, the link to it so that I can check on this for fix.

    You are always welcome to start a new thread, anytime for your any issues. If you have more issues like this, then you can brief it accordingly.

    It would always be my pleasure to help you with your issue. Le me know, if I can be helpful to you in any issues there.

    Regards,

    Sumit

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hello again @f. Zaria,

    Hope you are fine, today. :slight_smile:

    Please pardon me, if I'm not getting what you wanted to show me with the screenshot. Is it the word spacing or the line spacing (please see my attached screenshot).

    However, I modified the code in your main site and please check if current changes looks good. The code that I added is this:

    #footer a {
    margin-right: 0; /*spacing after hyperlinked words. (previous default was 20px)*/
    }
    #footer p {
    margin-bottom: 10px; /* spacing between two lines. (previous default was 15px)*/
    }

    Let us know, if the issue is persistent and if you have further queries related to this.

    Thanks,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.