Footer On Membership 2 Page

The footer bottom bar appears above the main footer on the Mebership 2 login page:

https://fade***.com/login/

However, this only happens when you see the site as a visitor (logged out user) when logged in, the footer is placed correctly

  • Kasia Swiderska
    • Support nomad

    Hello Brett,

    I checked both staging and live site login pages and reason why on live site footer breaks is because there are JS errors (in browser console). From what I observer some parts of the page are placed with JS script, so those errors are breaking that process.
    Two errors that can be seen on the live site does not show on the staging site. They are also not present after login.
    I wanted to double check the differences between staging and live site, but I am not able to login to staging with credentials that were provided during chat session.
    Can you enable support access to staging so I can take closer look?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Brett,

    I checked both sites and plugins from the live site are also installed on staging site - I can exclude that it is a conflict. What I noticed is that on live site there is Cache, which is not present on staging. It is not a plugin, so this would be something that hosting provider installed. Would it be possible to ask your provider to disable that cache for testing purposes? I'm asking for that because I have seen couple of times when cache from provider was breaking plugins.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Brett,

    :slight_frown: that did not help. Can you try with this beta version of plugin? It has some improvements for Divi theme.
    Because it is a beta, make sure you have a backup of the site.
    I suggest to not removing version you have now, but find membership directory in /wp-content/plugins and rename it (for example membership-old). Then unzip beta version on your computer and upload it plugins directory. While doing that don't open plugins page in wp-admin, so the change will be seamless.
    In case something will not work correctly you can then make renaming action in opposite way and switch back to stable version.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Brett,

    Okey, I know everything now. I tested login and redirect is only after login - so issue that you described in this thread https://premium.wpmudev.org/forums/topic/divi-membership-login-issue/#post-1302692
    So previous beta fixed problem with redirecting to login page, but this one doesn't have that fix and that is why login from other thread stopped working.

    I will notify developer that latest beta doesn't have fix needed for Divi and Login and get one that will have it.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.