Forgot Password Link uses Wrong Domain

I am experiencing an issue with (I think) the domain mapping plugin. There is another (subsequently closed) ticket that raises the same issue but this is a much newer multisite install.

On the login page for a mapped domain, domain for the forgot password link is the domain for the install itself, not the mapped domain.

  • Milan

    Hello @Adam,

    I hope you are having a good day and thanks for the asking. :slight_smile:

    On the login page for a mapped domain, domain for the forgot password link is the domain for the install itself, not the mapped domain.

    This is because its default wordpress mechanism of handling forgot password process. It's not related to Domain Mapping plugin at all. its default mechanism wordpress uses to handle forgot password link.

    I've noted that when I get my email setup, the mail that comes is also from the network, not from the individual site.

    Are you trying to register new site or new user ? Would you please advice me. ?

    Looking forward to hearing from you. :slight_smile:

    Cheers!
    Milan.

  • Adam

    Sorry Milan its been a really busy month. I totally forgot about this :slight_smile:

    The site in question is a convenience setup so a client can handle the marking of a range of products from one place. So as a rule, its not going to be a hassle that the forgot password is tied to the main domain. I think it would be an issue if I were running a more public business and the people I'm selling to expect their visitors to become WP users. In that scenario, the change of domain is going to confuse people.

    The email in question was for the forgot password email (and for creating new users).

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.