Form is not displaying because of an inline style

I have created 2 forms on my site and added them to their respective pages using the shortcode but for some reason one is not displaying, the other one works fine.

Running a plugin/theme conflict test returned the same results so we further investigated it during the chat and found that there seems to be a inline style “display: none” added to it that is causing this.

We added a new rule to the form “display: block !important;” under Appearance > Customize > Additional CSS to force it to be displayed but would like to know why that inline style was added to the form so I don’t need to use custom CSS to make it work.

  • James Morris
    • WordPress Enthusiast

    Hello Alex

    This issue has been flagged for our SLS Team (code experts) so that they can dig into this issue further for you. An update will be posted here as soon as more information is available. Thank you for your patience while we sort through this issue.

    Best regards,

    James Morris

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hi Alex !

    You had validation enabled on the Phone number but you didn't input any number to actually limit the number ( see attached screenshot - the 10 is a placeholder value set as an example ). This resulted in a jquery error ( it could be seen in your websites console ) so the form was hiding itself because it contained errors.

    I've removed the validation from the field for the time being, if you want you can re-enable it but please input a number for it to work properly. I've also removed your custom css style. You'll see that the form is shown properly now since it doesn't contain any errors.

    I hope this helps!

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.