Forminator CSS not working

Trying to customize the checkbox color via the default Customize Colors option in the Forminator, but the changes is only working in the Material Design Style, it doesn't work in Flat, and Bold Designs when implemented.

Please check the chat notes for more info.

  • Nithin

    Hello NuttyCart,

    Hope you are doing good today. :slight_smile:

    As mentioned in the chat, I was able to replicate the issue in my system for checkboxes, I'm marking this as a bug, and bringing into the developers attention, so that it would be fixed in the next plugin update.

    As a workaround, I have added the following CSS, in Appearance > Customize > Additional CSS section of your WordPress dashboard:

    #field-1520562761254-1400 > .forminator-field > .forminator-checkbox > .forminator-checkbox--input:checked+.forminator-checkbox--design {
    	background: #7c940c;
    }

    Please let us know if you have any further query related to this. Have a great day ahead. :slight_smile:

    Best Regrads
    Nithin

  • NuttyCart

    Hey, bud:

    Thank you for your help the last time. I just want to let you know the following observations -
    1. The CSS that you added is not working universally. It is limited to the form that we both worked upon when I lodged the complaint. None of the other forms that I created inherited the COLOR preference that you specified in the CSS.

    2. ALL your calendar functions are NOT working.
    -->The calendar picker does not even show up in the published form (browser).
    -->The other two options show up
    -->None of the three options gets submitted via email or show up in the backend entry report.
    *For now, I had to use text as a workaround and concatenated the combination to give me the date submission.

    3. The file upload function does NOT submit the attached files to either the email or backend submission report. It attaches but the attachment does not show up anywhere.

    I know the "forminator" is new but please help look into the above and advise on a resolution. By the way, all the forms that I created are live so I suggest you clone them and work on the cloned copies.

  • Kasia Swiderska

    Hello NuttyCart,

    1. The CSS that you added is not working universally. It is limited to the form that we both worked upon when I lodged the complaint. None of the other forms that I created inherited the COLOR preference that you specified in the CSS.

    That is correct with this CSS snippet because it targets specific field in form - those fields have unique ID, hence it will be not applied to other fields in other forms. In this case this CSS has to be used:

    .forminator-col > .forminator-field > .forminator-checkbox > .forminator-checkbox--input:checked+.forminator-checkbox--design {
    	background: #7c940c !important;
    }

    I already added it to your site, so all check boxes should be now green. I had to use !important directive in order to override blue color.

    2. ALL your calendar functions are NOT working.
    -->The calendar picker does not even show up in the published form (browser).
    -->The other two options show up
    -->None of the three options gets submitted via email or show up in the backend entry report.
    *For now, I had to use text as a workaround and concatenated the combination to give me the date submission.

    I can see issue on your site, but I am not able to replicate this on my test site. All 3 options are showing on form, calendar pickup shows correctly and entries are submitted:

    It looks like this might be conflict with other plugin or even a theme. If that is possible please run a quick plugin/theme conflict test as described in getting support manual E. Plugin Conflict Test
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    If it can't be done on live site, can you create a staging site for this test? Some hosting providers offer this feature. Another solution would be to use this plugin https://wordpress.org/plugins/wp-staging/

    3. The file upload function does NOT submit the attached files to either the email

    At the moment there is no option to add field of upladed file to email, but I'm checking with developers if that would be possible to add in future.

    l or backend submission report. It attaches but the attachment does not show up anywhere.

    I tested cloned form (/test-form/ page) and attachments are showing up for that form - you can see those in the entries for cloned form.

    I noticed that on original form page there are errors in console coming from the Facebook likebox in the sidebar. It might be that it is breaking upload fields.
    Can temporary remove that like box and see if then Upload will show in entries for that form?

    kind regards,
    Kasia

  • Nithin

    Hello NuttyCart,##1

    Can you please add a global CSS for radio buttons to inherit the same colour code as well?

    Sorry for the delay in getting back to you. I'm afraid, the support access got expired, so wasn't able to give a closer look at your forms.

    Could you please try the following CSS, and see whether it works fine in all forms in general:

    .forminator-radio .forminator-radio--input:checked+.forminator-radio--design {
    	background: #7c940c !important;
    }

    If the above CSS doesn't work, would recommend you to share the page link where the form is implemented, and also share your sites WP admin login credentials as mentioned below, so that we could give a closer look at your site.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin