Forminator does not work with OptimizePress

I have a website that runs on the premium theme of OptimizePress, I cannot use Forminator Quiz along with that.

I had set up a quiz on https://www.hu****ve.com/the-quiz/ and it did not load beyond the title.

  • Kasia Swiderska
    • Support nomad

    Hello Lise,

    I’m sorry about this issue caused by our plugin.

    I wanted to check this problem on your site, but I can see now that Forminator is removed from it.

    Please let me know if you still want us to debug this issue? I would need to install the plugin again and test it.

    kind regards,

    Kasia

  • Rupok
    • Support Ninja

    Hi Lise,

    I’m so sorry for the inconvenience. I could replicate the issue on your site. After investigating, I found that something on your site is putting a “display: none;” inline CSS to the Forminator forms.

    So I added the following custom CSS code in your Dashboard > Appearance > Customize > Additional CSS section and purged all your cache:

    .forminator-custom-form {
    display: block !important;
    }

    And that resolved the issue. I’ve added a test form in this page: https://www.hu************ve.com/test-form . It’s showing fine now.

    Can you please check and confirm? Is there anything else we can help you with?

    Regards,

    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello Lise,

    I was able to show the quiz with similar CSS code added, however, the quiz is not working correctly.

    There are JS errors in the browser console.

    We would need to have access to FTP (or cPanel if you have) to debug this further.

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Kasia Swiderska

    – FTP credentials (host/username/password)

    OR cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    IMPORTANT: Please make sure you select “I have a different question” for your topic, so it doesn’t go back to the forums – this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,

    Kasia

  • Lise Cartwright
    • New Recruit

    Those are the correct details… however I normally access my cpanel from within my SiteGround account dashboard vs. going straight to cpanel. My guess is that I’ll need to share the access to my SiteGround account.

    I’m not comfortable doing that. I think that for now, I’m not going to worry about using this plugin on my site.

    Thanks for all your help.

  • Rupok
    • Support Ninja

    Hi Lise Cartwright,

    We really want to find out why this is happening and resolve this issue for you. Is it possible for you to create a cloned/staging site of your current site so we can do the testing there? When we find the solution, you can deploy that in your live site.

    If you want, you can use our Shipper Pro (https://premium.wpmudev.org/project/shipper-pro/) plugin to create a copy of your site on WPMU DEV hosting (https://premium.wpmudev.org/hosting/). Please let us know when you are done creating the staging site and send us the credentials in the same way you sent the previous one. We will investigate and try to find out why this issue is happening on your site.

    I’m looking forward to hearing from you and resolving this issue as soon as possible.

    Regards,

    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.