Forminator exporting blank rows

Hi,

I have support access on for nfbga.org.

I'm use Forminator and I was testing out the export feature. I deleted some test entries on the Convention Reistration form. All the entries now are real. When I go to export the form entires as a CSV, there are blank rows that are visible. It shows the date but the rest of the row is empty. I'm assuming its the deleted data. Just wanted to let you know.

  • Ash
    • WordPress Hacker

    Hello cornelius_butler

    We have sent your issue to our second level support team. Please note that, they deal with more complex issues, so there might be little delay. We appreciate your patience on this.

    So, would you please send me your admin login and cPanel details (for file management and DB management)?

    Please send in the following format:

    Admin URL:

    Admin Username:

    Admin Password:

    cPanel/Hosting URL:

    cPanel/Hosting Username:

    cPanel/Hosting Password:

    You can send me privately in the following format:

    1. Please go to https://premium.wpmudev.org/contact/#i-have-a-different-question

    2. Select “I have a different question” if not selected

    3. In subject line put “Attn-Ashok” (this will ensure that the email is assigned to me)

    4. Provide the requested details.

    5. Add this thread link in the message so that I can track.

    Please do not post any sensitive information in the forum as the forum is public and everyone has access to it.

    Have a nice day!

    Cheers,

    Ash

  • Alessandro
    • Staff

    Hello, cornelius_butler, thanks for using Forminator!

    I investigated your issue, and I am back with a small snippet.

    Using this snippet you will be able to show or hide blank rows into your export.

    Set the following variable to true to export even blank rows. Table columns are prefixed with a caret (*).
    $form_fetch_blank_rows

    Download it here:
    https://gist.github.com/wpmudev-sls/f39ecf0802bfb8ccd1bc51e65b6bffa1

    If you want to know more on how to install a mu-plugin, visit this link:

    Must Use Plugins

    Briefly, get it and then upload it (the *.php file) in your wp-content/mu-plugins (if directory does not exists, create) and put the snippet under that directory.

    Let us know if this worked for you.

    Note: Because these fields missing settings, their content maybe be strange. We fetch them as is from the database. This is totally normal and expected behavior as these fields were deleted before and exist as submission data in the database.

    Kind regards,
    Alex.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.