Forminator form does not work when branda SMTP is configured

I have SMTP configured in Branda and have Forminator form created. The Forminator form does not work when Branda SMTP is configured.

  • Nithin
    • Support Wizard

    Hi Matteo,

    I tested in my system, and I'm not able to replicate any such issues when tested in my website hosted in WPMU DEV Hosting with Branda SMTP, and Forminator. The emails do get sent without any issue.

    I checked in your system and enabled Branda plugin, and the SMTP settings and a test email did get sent without any issue.

    When checking Forminator forms, I tried to test these forms:

    /richiedi-un-contatto/
    /contatti/lavora-con-noi/

    And could notice the following error:

    An error occurred processing the form. Please try again

    I created a test form to see how that behaves and could notice the above error when Branda SMTP was enabled. On checking further the issue was with no Email Headers configured in the Branda side.

    I tested by adding the admin email, and From name and the form worked fine with Branda SMTP configuration. I have reverted the changes and deactivated the plugin.

    Please do add a From email, and name and then check whether you still have any issues or not with email getting processed.

    Kind Regards,

    Nithin

  • Matteo
    • Site Builder, Child of Zeus

    Hi Nithin,

    First, thank you very much for your quick response.

    I did as you suggested, and now the forms are submitted with no troubles. Still it sounds strange to me that i have to overwrite the senders name and adress for the SMTP to work, but the important thing is that it works now, so thank you very much.

    I still have a problem with forminator though. The form in this page: https://cooplameridiana.wpmudev.host/contatti/lavora-con-noi/

    There is a file upload button, and it actually won’t work. Even if users click on the button, no “upload window” is opened, nothing happens.

    May you be so kind to look into this problem? i think it is somehow related to the SMTP one, it’s like for some reason there are javascript errors that do not let forminator work as it should.

    Thank you very much

    Matteo

  • Nithin
    • Support Wizard

    Hi Matteo,

    Still it sounds strange to me that i have to overwrite the senders name and adress for the SMTP to work, but the important thing is that it works now, so thank you very much.

    The issue occurred due to the blank Email Heders in the SMTP side, which was overriding the default email headers and hence causing an issue. Once the Email Headers were added it started to work fine as you have stated.

    I still have a problem with forminator though. The form in this page: https://cooplameridiana.wpmudev.host/contatti/lavora-con-noi/

    There is a file upload button, and it actually won’t work. Even if users click on the button, no “upload window” is opened, nothing happens.

    On checking the console errors, I could notice there is error specifically generating from the Divi Mega Pro plugin.

    Uncaught TypeError: Cannot read property '_tippy' of undefined main.js?ver=1.1.1:1326

    The error is pointing to the following file:

    https://cooplameridiana.wpmudev.host/wp-content/plugins/divi-mega-pro/assets/js/main.js?ver=1.1.1

    Could you please disable the mentioned plugin, and then check whether the conflict with Upload button still exists? This would give a better idea of where the issue is, and see whether there is any workaround that could be looked upon.

    Looking forward to your response. Have a great weekend.

    Best Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.