Forminator Pro: AM/PM dropdown not inline

I built a form in Forminator that has time boxes. I selected the dropdown boxes and notice that the AM/PM dropdowns are not inline with the time. See this screenshot: https://cl.ly/98ca786de7d2

Anyone know why? I also see that some boxes are a dark grey and the rest aren't. Thoughts there?

  • Jo4nny8
    • Design Lord, Child of Thor

    It looks like select box styling is different (for the greying issue)

    Check your css.

    Regarding the inline issue, I suspect it’s due to not having a label and it’s screwing up the styles. Can you add negative margin or padding to those elements? - give them a custom class on forminstor

  • Dimitris
    • Support Star

    Hello there Swami,

    hope you're doing good today! :slight_smile:

    As this is about a support request of a plugin of ours, I've moved this thread from Members forums to Support forums. Please use this when you're seeking our support services and Members forums when you need to attract more WPMUDEV members.

    Now, on the issues themselves, I tried to replicate in a local site of mine, with no avail though!

    This should be happening cause of the active theme you're using. In order to have a better look at it and provide some CSS to override this, could you please grant temporary support access via WPMUDEV Dashboard plugin? No need to share any WP admin credentials. Just navigate in WP admin area under WPMU DEV -> Support page and click on the "grant support access" button. You can find detailed information about it here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5
    Please do reply back here when access is granted because we don't get any notifications about it.

    Warm regards,
    Dimitris

  • Swami
    • Flash Drive

    I granted access. I also have another issue that's related. I've set the background on my form to light blue. It works on some form fields, but not on others. (Which is super weird.) I'm assuming it is a CSS issue, but not sure how to go about fixing it. I don't want to change those colors at a theme level, since they affect other pages. Do I need to create a custom CSS class and apply it to each field? Can you tell me why the color is working on some boxes, but not others? See here: https://cl.ly/dd572efb36e6

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.