[Forminator Pro] Bug in Forminator Pro

FYI, when using Forminator Pro on a wordpress multisite, it always fails in the captcha settings page when entering credentials for any non-root site. However it works on the front end. Perhaps the settings page should check to see if the site is mapped to a different url with the domain mapping plugin?

  • Ash
    • WordPress Hacker

    Hello AndrewTraub

    Let me understand the scenario.

    You are having a multisite, and some of your subsites have mapped domain. And in the backend, the captcha settings fails. If that is the case, does it fail for subsites with mapped domain or all subsites?

    If I misunderstood, please feel free to suggest and I will test accordingly.

    Have a nice day!

    Cheers,
    Ash

  • Dimitris
    • Support Star

    Hello there AndrewTraub,

    hope you're doing good today! :slight_smile:

    This seems to be a case of allowed domains in the Google Captcha API keys.
    To better explain, it depends on the domain name used in the administration pages, which is also coming from a Domain Mapping setting. If you use the mapped domain to access it, then the mapped domain should also be included in the allowed domain in Captcha panel. If you use the original domain, then the original domain should be added in the allowed domain in Captcha panel. If you use the option for both domains (whichever user selects), then both should be added.
    I've made some tests with all these and I can confirm that these actions remove the aforementioned errors.
    Hope that makes sense, let me know if further assistance is required.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.