[Forminator Pro] Can't Create forms

Hi there, I am trying to add a new contact form however I can't "create" any, every time I click on the button nothing happens, I have deleted and reinstalled forminator and reinstalled WP, any idea why it's not working, I have set them up on some of the other sites no worries

cheers Adrian

  • Predrag Dubajic
    • Support

    Hi Adrian,

    This suggests that there’s a conflict somewhere on the site that is most likely breaking scripts on Forminator page so it’s unable to start form builder.

    Can you perform a full conflict test by disabling your other plugins and switching to default WP theme to see if you’re able to create a form after that?

    If it works then activate them back one by one until you see which one is causing the issue and we can debug it further from there.

    It’s strongly suggested to have a full site backup ready before performing this test.

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Adrian,

    Are the sites configured in the same way? It’s possible that a specific option that conflicts with Formaintor is enabled only on this site and is causing the issue.

    You could grant us support access to your site by following this guide https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    so we can check it out but these cases are mostly due to a conflict.

    We’ll gladly check it with the support access but if you can create a staging site where we can test this without affecting live installation it would give us more room for debugging.

    Best regards,

    Predrag

  • Adrian Marshall
    • WPMU DEV Initiate

    Hi Predrag

    I have just given support access, I have put in a ticket about an hour ago in regards to restoring backup’s failing – “Restoration failed” error, I am wondering if it’s related. I tried to restore both backups hoping to see if that would solve the issue however both backups failed to restore.

    I have also noticed that if I click on the backup “show log” file nothing comes up and if i try and add plugins and click on “more details” when adding a new plugin it freezes the plugin screen.

    I am happy to create a staging site I have 3 available on your server, how do I do that? is that the best option?

    cheers Adrian

  • Predrag Dubajic
    • Support

    Hi Adrian,

    There are definitely some issues on your installation, not just on Forminator panel, any page that I opened had over 60 console errors are referring to JS files.

    It shows 500 errors for pretty much any JS file loaded on page and since it’s a 500 error we might be able to get further information by checking debug log.

    You can enable debug log in your wp-config.php file (located in root WP folder) by replacing define(‘WP_DEBUG’, false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);

    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);

    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'log_errors', 1 );
    @ini_set( 'display_errors', 0 );

    Visit Forminator page in your admin and this should create debug.log file in your wp-content folder that could tell us what is going on.

    Can you please save it as .txt file and attach it here so we can check it out.

    Let’s see if this will give us some further information before going for a staging site because migration can be a lengthy task and with all of the JS errors it would probably not be possible to use migration plugins.

    Best regards,

    Predrag

  • Abdul Wajed
    • Staff

    Hi Adrian,

    As Predrag mention earlier a lot of console error occurring in every admin page of your site, there are definitely some issues on your installation and as nothing in the debug log as you mention we need to investigate it further. Wouldn’t you mind please provide some credentials so that we can check further for the solution.

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: “Attn: Abdul Wajed”

    – Site login URL:

    – WordPress admin username:

    – WordPress admin password:

    – FTP/SFTP credentials

    Host:

    Username:

    Password:

    Port:

    – cPanel credentials (If any)

    Host:

    Username:

    Password:

    – Folder path to the site in question:

    – Link back to this thread for reference

    – Any other relevant URLs/info:

    Please, reply to the ticket once you have sent the information.

    Best Regards

    Abdul Wajed

  • Adam Czajczyk
    • Support Gorilla

    Hello Adrian Marshall

    Thanks for providing access.

    I checked the site and found out that there’s Defender’s “Prevent PHP Execution” security tweak applied. This tweak creates additional .htaccess files, one of them being in “wp-includes” folder – all the JS files that were triggering 500 error in browser console were from that folder.

    So I checked the file and found out that in addition to Defender’s rules, there were some additional rules added. They were supposed to do the same but weren’t complete. I believe they were either added by some other plugin or were some sort of “leftovers” from some attempt to manually secure the site.

    The bottom line is: I’ve removed those additional rules leaving only working ones coming from Defender (from the .htaccess file in /wp-includes folder) and that fixed all these 500 errors for JS files, causing all these files to load properly.

    This fixed the Forminator issue (you can see that I created some empty form already, just to test it) and some other issues that my colleague Predrag mentioned earlier.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.