[Forminator Pro] Data not loading for Forminator poll

Last night I installed Forminator (free) and set up a poll. This morning I sent my newsletter linking to the poll and then renewed my expired WPMU membership. Now I can see that people are clicking to the poll and entering data, but the "view data" option on my poll just runs "loading data" animation forever. And ever. Refreshes, etc. have no effect.
My site shows Forminator installed, the Hub shows Forminator Pro, though I have not updated/upgraded it. I'm not sure if that's a problem. I don't want to deactivate and reinstall while my newsletter is being opened and clicked by thousands of people.

Any suggestions? Thanks!

  • Ash

    Hello Shinteetah

    Let me answer your last question first.

    My site shows Forminator installed, the Hub shows Forminator Pro, though I have not updated/upgraded it. I'm not sure if that's a problem. I don't want to deactivate and reinstall while my newsletter is being opened and clicked by thousands of people.

    Forminator free and pro version are exactly same, so when you have an active membership it shows as pro.

    Now about the issue, please open the poll page on chrome, right click on chrome, select inspect, select console, refresh the page and click on "View Data" again. Do you see any error in red color in the console, if so, then it might be a conflict. In that case, please run a conflict test. Please deactivate all plugins except this one and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1

    Let us know how it goes. Have a nice day!

    Cheers,
    Ash

  • Shinteetah

    Thanks for a quick reply!

    Deactivating all plugins but Forminator results in the same loading problem. Nor does a theme switch solve the problem. (Everything is up to date as well!)

    The Chrome console did show an error:

    WebSocket connection to 'wss://public-api.w public-api.wordpress.com/:6 WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403

    That's how it reads, but I think the two links are actually
    wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data
    https://public-api.wordpress.com/wp-admin/rest-proxy/?v=2.0

    I'm not knowledgeable enough to work out what to do with this.

    The only other thing I can think of would be something that Hummingbird has optimized, but that should have been turned off when I deactivated all plugins.

    Thanks!

  • Nithin

    Hi Shinteetah,

    It's odd it f the poll isn't working even after disabling all the plugins. The error showed in the console is related to JetPack plugin, however if you have tested when the plugin was disabled, it shouldn't have been causing it.

    Could you please share the page link where the poll is added? And also, please grant support staff access so I can take a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.