[Forminator Pro] Having trouble creating Poll in Forminator

I am unable to create a Poll. After clicking the "+Create" button, I enter a Name for the new poll and Submit "+Create". After the page reloads, the area where I should start building the Poll is blank. I am able to create Forms and Quizzes…but the Polls don't work. I also tried on another site and had the same exact issue. Any help you can give me is appreciated. Is there a list of known plugin conflicts? Thank you.

  • Ash
    • WordPress Hacker

    Hello Michael

    It looks there is a conflict with any other plugin or theme.

    Would you please run a conflict test? Please deactivate all plugins except this one and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1

    Let us know how it goes.

    Have a nice day!

    Cheers,

    Ash

  • Rupok
    • Support Ninja

    Hi Michael,

    Can you please turn on debug mode in WordPress (if it’s not turned on already)? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    Also add the following lines there:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    The errors will be saved to a debug.log log file inside the /wp-content/directory.

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If the file is very long, paste them to a text file and attach with your reply.

    I’m looking forward to hearing from you and resolving this issue as soon as possible.

    Regards,

    Rupok

  • Michael
    • New Recruit

    This is the only error that is reporting:

    11-Aug-2019 14:45:07 UTC] PHP Notice: Undefined index: SERVER_NAME in /var/web/staging/public_html/wp-includes/rest-api.php on line 378

    It is happening on Production and Staging.

    Thank you.

  • Kasia Swiderska
    • Support nomad

    Hello Michael ,

    I have replicated this issue on my site with Bridge theme and Forminator. It looks like Bridge theme is breaking sets of JS scripts that are only used for polls (that is why other modules are working correctly).

    I’m going to report it to developers and they will see if that is something that we can fix on our side.

    kind regards.

    Kasia

  • Michael
    • New Recruit

    I found this support article. I’ve used this theme for a longtime, and wasn’t aware of the changes they made to the child theme…after making this fix, the Formniator Poll works as expected. You can close the ticket, thank you for all of your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.