[Forminator Pro] Jquery error formnator Pro integration with google sheet

When i set the integration with google sheet i had this error : Uncaught TypeError: Cannot read property 'success' of undefined

at Object.success (front.multi.min.js:1)

at i (jquery.js:2)

at Object.fireWith [as resolveWith] (jquery.js:2)

at y (jquery.js:4)

at XMLHttpRequest.c (jquery.js:4)

And any confirmation of the sender form.

  • Dimitris
    • Support Star

    Hello there Diego Díez Corral,

    hope you’re doing good today and thanks for reaching us! :slight_smile:

    I just tried to replicate this in a testing site of mine, with no avail though.

    I was able to finish the Google Sheet integration in Forminator Pro -> Integrations, then assign it in a form and use a path of my Google Drive as well as a file name. The new file was created with success and new submissions of the form were getting logged in there within seconds.

    Also enabling WP_DEBUG during all that process didn’t log any error log like the one you’ve shared above.

    Could you please let us know what’s the exact steps you’ve made and how and where exactly did you get this error message? Please advise, so we can try to recreate this once more.

    Warm regards,

    Dimitris

  • Diego Díez Corral
    • The Crimson Coder

    Hi there, I still had this problem.

    The output is:

    Uncaught TypeError: Cannot read property ‘success’ of undefined

    at Object.success (front.multi.min.js:1)

    at i (jquery.js:2)

    at Object.fireWith [as resolveWith] (jquery.js:2)

    at y (jquery.js:4)

    at XMLHttpRequest.c (jquery.js:4)

    I set the debug, but i cannot see any problem with anothers plugins.

    This site is under a wordpress multi, I had the avada configuration but the error only appears in this form, because i had another form in this subsite, and havent the problem.

    If i set a redirection url with ajax, the output is error 500

    If i set the redirection url the output its the error:

    Uncaught TypeError: Cannot read property ‘success’ of undefined

    at Object.success (front.multi.min.js:1)

    at i (jquery.js:2)

    at Object.fireWith [as resolveWith] (jquery.js:2)

    at y (jquery.js:4)

    at XMLHttpRequest.c (jquery.js:4)

    If i send a normal form the putut its Uncaught TypeError: Cannot read property ‘success’ of undefined

    at Object.success (front.multi.min.js:1)

    at i (jquery.js:2)

    at Object.fireWith [as resolveWith] (jquery.js:2)

    at y (jquery.js:4)

    at XMLHttpRequest.c (jquery.js:4)

    This error only happens with the google sheet integration On, i set this url like no cacheable in the litespeed cache…

  • Nahid
    • Tech Support

    Hey Diego Díez Corral !

    Hope you are doing well today!

    In order to investigate the issue, I tried to access the site, but the Support Access didn’t work. Could you please send us the access credentials to your site and server so that we can take a closer look at the issue? You can send that privately through our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: “Attn: Nahid Mohit”

    – WordPress Admin Username

    – WordPress Admin Password

    – Login URL

    – FTP/cPanel credentials to the site files (host/username/password)

    – Link back to this thread for reference

    – Any other relevant URLs

    Hope this helps. We’ll be looking forward to hearing back from you. Thanks!

    Kind regards,

    Nahid

  • Nahid
    • Tech Support

    Hey Diego Díez Corral !

    Hope you are doing well today!

    Thank you for sending in the credentials. I tried to replicate the issue on your site by logging in using the provided credentials, creating a test Forminator form and integrating it into a Google Sheet and lastly putting the form in a created test page. I was not able to see any errors in the browser console upon successful submission of the form. Here's a screenshot for reference:

    Moreover, the form entry was also successfully added to the said Google Sheet. Here's another screenshot for reference:

    Could you possibly point us to the specific form where you're seeing this issue so that we can investigate further?

    We'll be looking forward to hearing from you. Thanks!

    Kind regards,

    Nahid

  • Nahid
    • Tech Support

    Hey there Diego Díez Corral !

    Hope you are doing well today!

    Thank you for getting back to us with the form location. This issue seems to be specifically happening in the “tempero” subsite. Could you please go through the following troubleshooting test which would help us determine the source of the issue?

    Plugin/theme conflict test: Try running a full plugin/theme conflict test just to make sure no other plugin(s)/the theme on your site is/are conflicting with Forminator Pro and thus causing the issue. The basic concept is to temporarily disable all the plugins except Forminator Pro and WPMU DEV Dashboard, switch to a default WordPress theme and check if the issue still persists. If it doesn’t, please enable all plugins and the theme one after another to see activating which brings back the issue. This handy flowchart can help you do a full plugin/theme conflict test.

    Note: It is highly recommended that the site is backed up before the tests or the tests are done in a cloned staging site.

    We’ll be looking forward to hearing back from you. Thanks!

    Kind regards,

    Nahid

  • Nahid
    • Tech Support

    Hey there Diego Díez Corral !

    Hope you are doing well today!

    I tried multiple times but I’m afraid I was not able to access the provided URL. Upon my request, multiple colleagues tried to access the URL but they failed as well. It gave us an “ERR_NAME_NOT_RESOLVED” error. Is there something we need to do in our end to access this URL, like adding entries to our hosts file or using a specific port?

    As the form isn’t working in your staging site, may I know if you were able to go through the troubleshooting tests that I suggested in my previous response? If not, would you be able to give them a try?

    We’ll be looking forward to hearing back from you. Thanks!

    Kind regards,

    Nahid

  • Diego Díez Corral
    • The Crimson Coder

    Sorry, we do some changes with the staging, the correct url is:

    https://app-5bed6ec2f911c801a8826cb9.closte.com/tempero/

    https://app-5bed6ec2f911c801a8826cb9.closte.com/luisfvaciero/

    Its strange because all the sites are the same configuration and the plugin work well in https://app-5bed6ec2f911c801a8826cb9.closte.com/arapilesuniv/

    I set for you the access in the background, and this will not change anything instead you contact for do some another tests…

  • Nahid
    • Tech Support

    Hey there Diego Díez Corral !

    Hope you are having a great day!

    I’m extremely sorry about the delayed response here. Thank you very much for setting up the staging site for us.

    I was able to see that the form named “Cena de antiguos 2018” doesn’t work in the /tempero/ site that you indicated above. However, I was able to see a different error in the browser console. Here’s a screenshot for reference:

    The other two forms in this site were working as expected with no errors in the browser console.

    In the /luisfvaciero/ site indicated above, I couldn’t find a page which contains the form, so I created a test page and placed the created form temporarily for testing. I was able to see that on form submission, the page just reloads and the submission is not logged. However, I wasn’t able to see any errors in the browser console.

    Could you please make sure if the tests mentioned in my earlier response were done in this site? If not, could you please initiate them and let us know how that goes?

    Hope this helps. We’ll be looking forward to hearing back from you. Thanks!

    Kind regards,

    Nahid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.