[Forminator Pro] Material design stylesheet not included

Dear Support,

I have encountered an issue regarding my Forminator pro v1.7.1.3 form. When I select the Material Design in the Appearance tab of the form. The styling appears missing from the Material Design core style. The forminator-forms.min.css is also missing from the source code and is not included.

I hope you can point me in the right direction to get the Material Design styling applied to the Forminator Forms.

Thanks in advance.

  • Kris
    • Support

    Hi Justin

    Hope you are doing good today.

    I try to replicate this issue on my test lab with current version and with Material Design but design works well and forminator-forms.min.css load correct in page source.

    Could you download current version of Forminator from here:

    https://premium.wpmudev.org/project/forminator-pro/ and re-upload all files and folder via FTP to /wp-content/plugins/forminator/.

    If that does not help please provide support access for this site. You can grant support access via

    WPMU DEV > Support > Support Access

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Kind Regards,

    Kris

  • Justin
    • WPMU DEV Initiate

    Hi Kris,

    Thanks for your awesomely fast reply! I’m doing fine, thank you. Hope you are having a great day as well.

    I just downloaded the plugin manually and uploaded the plugin via FTP as you suggested. Unfortunately this didn’t fix the issue. So I have just set up Support Access for the domain. If you need more information let me know ok?

    Thanks for the help and fast support!

    Kind Regards,

    Justin

  • Kris
    • Support

    Hi Justin

    Thank you for support access. I see that case is more complicated.

    I create second test form and I place that form on test page.

    On test page:

    1. form design loads ok

    2. forminator-forms.min.css load in source

    3. footer original form loads ok as well (please check page /test-form/)

    I see that form is added in Options -> Footer module which possibly is build in part in your theme and this module conflict with Forminator to load those styles.

    To investigate this more and escalate this to developers to take closer look I will need below data.

    Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is “I have a different question” and:

    – Mark to my attention: ATTN: Krzysztof Tomczyk

    – Site access(login URL/ username / password)

    (support access could expire at some point that is why we need login and password)

    – FTP credentials (host / username / password / port)

    – Link back to this thread

    Please don’t share any sensitive information (i.e credentials) in the Support Forum, it has public visibility and everyone will have access to it.

    Please confirm here in thread that you have sent that message.

    Kind Regards,

    Kris

  • Kris
    • Support

    Hi Justin

    Thanks you again for all data. This issue has been flagged now for our SLS Team (code experts) so that they can dig into this issue further for you. We will post an update here as soon as more information is available.

    Please keep in mind that our SLS Team deals with more complicated issues, so it may take a little longer for them to reply here. Thank you for your patience while we look into this further.

    Kind Regards,

    Kris

  • Justin
    • WPMU DEV Initiate

    Hi Kris,

    I’ve granted your for another 5 days.

    Please note that FTP login details are not working, if you have any, I think my colleague send you those but our server is IP secured and then your IP address needs to be whitelisted. You can always send me the developers IP address and I will whitelist is right away.

    If you need anything please let me know.

    Kind regards,

    Justin

  • Panos
    • SLS

    Hi Justin !

    Thanks for extending support access!

    I notice that the shortcode is added in a theme field and not in a page/post content. That some times can cause such issues when shortcodes need to enqueue scripts and styles. I believe adding the following in a mu-plugin or your Child theme’s functions.php (make sure you are using a child theme though so you don’t lose your changes upon theme updates) :

    add_action( 'wp_head', function(){
    forminator_print_front_styles();
    }, 999);

    should do the trick.

    If after adding that it still doesn’t add the styling you can whitelist the following IP : 2.86.33.17.

    I would also need admin and ftp access. Could you re-send those to be sure I have the correct ones? You can send them in You can send that privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:Subject: “Attn: Panos Lyrakis”

    – Admin login:

    Admin username

    Admin password

    Login url

    – FTP credentials

    host

    username

    password

    (and port if required)

    – link back to this thread for reference

    Kind regards!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.