[Forminator Pro] Styling Issue with Forminator Pro

Hi,

I have several drop-down "Select" fields in my form under the Fields tab, but I am unable to select the color options for them. No option appears for the "Select" field in the color options under the appearance tab.

I am able to select color options on other sites within my account, but not this one. Please advise.

Thank you.

  • Dimitris
    • Support Star

    Hello there Brian,

    hope you're doing well!

    This is true as there're no specific settings for the Select fields.
    For these you can use some custom CSS like below:

    .forminator-select + .select2 .selection .forminator-select2 .select2-selection__rendered {
      color: red;
    }
    .forminator-select + .select2 .selection .forminator-select2 {
      background-color: lightgray;
      border-color: green;
    }
    /* on hover - start */
    .forminator-is_hover .forminator-select + .select2 .selection .forminator-select2 .select2-selection__rendered {
      color: black;
    }
    .forminator-is_hover .forminator-select + .select2 .selection .forminator-select2 {
      background-color: green;
      border-color: lightgray;
    }
    /* on hover - end */

    If you need further assistance with the custom CSS, please do let me know what exactly you're trying to accomplish and I can share some more detailed CSS rules.

    As for the issue itself, I've already pinged our developers about it, as some styling support over there would make perfect sense in my opinion. :slight_smile:

    Warm regards,
    Dimitris

  • Dimitris
    • Support Star

    It seems that there's a bug somewhere so I'm pushing this to our developers for further investigation.
    Meanwhile, I was able to make the dropdown options to appear by adding a Time Picker field in my testing form. Until this is fixed in a future release, you can just add a field like that, assign to it a custom class and use some CSS to hide it (let me know if you need further assistance on this).

    Warm regards,
    Dimitris

  • Brian
    • WPMU DEV Initiate

    Ok I added a Time Picker field to my form. Then I went to the Appearance section and the Select Field color options were now available. I changed the options to my own styling and hit save. I then checked my form, but the colors are still showing the default colors. I just wanted to let you know what it was doing on my end.

  • Brian
    • WPMU DEV Initiate

    Hi. I hope you had a good weekend.

    I wanted to check up and see how the developers are doing with the update for Forminator. I wanted to see if they found the bug, because I really need to get this form done.

    Thank you.

  • Pawel
    • Staff

    Hello there Brian!

    We also hope you had a great weekend!

    We appreciate your patience on this and I'd like to assure you that we are looking to solve this issue. I've checked the task created by Dimitris and the developers are already working on providing a fix. There is some discussion and testing already carried out with the upcoming version of Forminator, but no definite solution is available yet. Please give us some time and check in back later, maybe we'll have a fix ready for you, although we can't give you any guarantee on when exactly it will be available.

    Kind regards,
    Pawel

  • Dimitris
    • Support Star

    Hello there Brian,
    hope you're doing well today! :slight_smile:

    There's a fix being tested with upcoming v.1.7 by our QA team currently. As soon as it passes all of their tests, then it will be published, so keep an eye in WPMUDEV Dashboard or in your Hub for a plugin update notification.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.