Forminator translation doesn't work for two strings

I am trying to translate a few strings which don't seem to work for me. They are not reflecting changes, they are actually errors on the form fields you can find on "/test2" https://cdn.livechat-static.com/api/file/v2/lc/att-old/8801096/450828bb2fec3edc6278fa6ceb98c7ae/Screenshot%20from%202019-06-16%2017-16-52.png

The other issue is the date field calendar doesn't show month and year https://cdn.livechat-static.com/api/file/v2/lc/att-old/8801096/9e65c30b1a388191b77a1657fb2389ad/Screenshot%20from%202019-06-16%2017-44-20.png

Additionally, I have selected date dropdown in the back-end, then selected the default date to be "none" but it still has a date.

You can find all these issues on the page "/test2"

  • Adam Czajczyk
    • Support Gorilla

    Hello AU

    I hope you're well today and thank you for your question!

    Forminator is already translated in most parts to other languages. The German translation is currently 73% complete so some strings are still not translated but I did check this translation and the message in question is translated there and does work. Could you please give it a try instead of Loco Translation - to check if it works for you?

    As this translation is confirmed to be "technically" valid, that would possibly show if it's a problem with Loco or something on site is conflicting. You'll find German translation here:

    https://premium.wpmudev.org/translate/projects/forminator/de/default/

    To apply it to site, scroll the page all the way down and use the form below to export both .mo and .po files and upload these files to the "/wp-content/languages/plugins" folder of your WordPress install.

    The other issue is the date field calendar doesn't show month and year

    This happens because there's a CSS rule applied to all "select"-type fields that hides them. It's coming from a CSS "/wp-content/uploads/stm_uploads/skin-custom.css". I believe it's related to one of the "STM" series plugins that you got installed on site.

    A simple way to override it would be to add following CSS to the site:

    #ui-datepicker-div select {
    	opacity:1;
    	visibility:visible;
    }

    You can add it for example via "Apearance -> Customize -> Additional CSS" or via some "custom css" option of your currently active theme (if there is such option).

    Additionally, I have selected date dropdown in the back-end, then selected the default date to be "none" but it still has a date.

    I tested it on my own setup and can confirm that so I consider it a bug. I've already reported it to our developers so they'll look into it and work on a fix. Please make sure to keep the plugin up to date and also keep an eye on this ticket in case we had some additional information or some "patch" for you meanwhile.

    Kind regards,
    Adam

  • AU
    • WPMU DEV Initiate

    The translation didn't work even with those files.

    The css worked and I will be switching over my date fields to the calendar picker option anyway where there is no error message so issue is solved for me, thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.