Forminator visibility conditions

I am getting issues in my form since the last update (Version 1.7.0) this was working properly before.

Basically, if you open the form, you should only see the first radio choice between sofortkauf (instant-buy) and finanzierung (financing).

If you choose instant buy, you should see some fields then, including the ones at the bottom of the form, like comment field, send button etc.

However, if you choose financing, you get send to the 2nd big radio option.

"als pdf-datei runterladen und ausfüllen" download as pdf and fill out manually or "jetzt online ausfüllen" fill out the online form now.

When selecting the pdf option, you should see no more fields except the one html field with the download link to the pdf.

If you select the online form, that's when you get the whole load of fields.

  • Ohidul Islam
    • Staff

    Hi AU,

    I hope you're fine today and thank you for reporting this!

    I was able to replicate that on my test setup and I can confirm the issue.

    We have sent this issue to our second level support team. Please note that, they deal with more complex issues, so there might be little delay.

    They'll look into it and create a fix. Please keep the plugin up to date and also keep an eye on this ticket in case we had additional information or some sort of "patch" for you meanwhile.

    Kind regards,
    Ohid

  • AU
    • WPMU DEV Initiate

    Hey,

    alright thanks. My guess is it has to do with the fact that the visibility of fields on "level 3" are depending on a radio selection on "level 2", whose visibility itself depends on a radio selection on "level 1". So possibly any kind of chaining of fields using visibility rules is causing issues, not only radio maybe, but did not check that myself.

    Cya

  • Ohidul Islam
    • Staff

    Hello,

    Yes, you may got it right. Right now the fields on "level 3" depends on the trigger of "level 2" selection, whatever it is radio/checkbox or select field. I have bring this to our developers attention, they will look into the issue.

    Please keep an eye on this thread, as soon as we have updates about this issue we will notify you.

    Kind regards,
    Ohid

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hey AU ,

    We've identified the issue and I've applied a patched file on your installation. This fix will be included in the next release as well so feel free to update as it won't break these changes.

    I'm also attaching the file in case you have more installations with the same issue for the time being.

    In your server at the folder located at wp-content\plugins\forminator\build\front you will find a file named original_front.multi.min.js and the patched front.multi.min.js. Similarly if you experience this issue on another installation simply download the zip and extract it and upload the fixed file on the mentioned folder.

    Please do a thorough test of your form as well for a confirmation!

    Regards,
    Konstantinos

  • AU
    • WPMU DEV Initiate

    Hey there,

    thanks for all your work. I did some testing but I think it's still not fixed. If you go to the main page of my multisite there is a test form and a test page where it is embedded. This is basically showing a broken down version of a part of my big forms and it replicates the issue I am having on the real form.

    Expected behaviour: if you select private in radio 1, private number field shows up. If you then switch to business, private number field disappears, because its rule is no longer valid and it should switch to hide, then radio 2 choice shows up.

    What happens: once you select private in radio 1, the private number field never disappears again. This is especially problematic if the fields which do not disappear are required fields, just as I set it up in my test form. They stay required even if they should be hidden and you can't send the form unless you fill out fields which should be hidden and not required based on selection.

    So for example if a commercial customer mistakenly clicks on the option that he is a private customer, 20 mandatory fields related to private customers pop up. He then corrects his choice to commercial customer and the correct 40 mandatory fields for commercial customers pop up. He is confused by the 20 private fields remaining visible, but skips them and fills out the 40 correct ones. When he tries to send, all 20 private fields light up red, forcing him to fill them out.

    Hope I could explain and sorry for my delayed testing. Thanks for your work!

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hey AU ,

    Have you re-applied the file maybe? That fix is to be shipped with 1.7.1, but since 1.7.0.1 came out that file was overwritten so it has to be replaced again. Maybe that's why you're experiencing the same issue again :slight_smile:.

    Please tell me if you want me to re-apply the changes for you!

    Regards,
    Konstantinos

  • AU
    • WPMU DEV Initiate

    Hi,

    I re-applied the file. Issue still persists on the test form, you can check it on the main site of the multisite, page called "test". Radio 1 option 1 related field never disappears if you switch to radio 1 option 2.

    Thanks

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hey AU ,

    I'm seeing this behaviour on the form that has each option change individually as supposed to https://www.loom.com/share/24084e7331894eb5b5eecd32bd29e9c4 . As far as I could see from the settings this is how it's supposed to work as well, am I missing something extra here maybe?

    Did you clean your browsers cache as well just in case your browser still has the older file cached?

    Regards,
    Konstantinos

  • AU
    • WPMU DEV Initiate

    Yup, that seemed to have worked. Must have been a combination of me not having yet re-applied the patch and after I did not clearing the cache. Issue should be solved for now, thanks for the help!

  • AU
    • WPMU DEV Initiate

    Sorry, nevermind. The issue of hidden required fields staying required still persists. Do the following steps to reproduce:

    1. select private
    2. select commercial
    3. select either small or big business
    4. switch back to private
    5. enter private number field and try to send

    The form will give you an error and if you then recheck the small/big business number field you will see that the last one you selected but afterwards made hidden will stay required.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.