Forums plugin language support

Hello,

I purchased the WPMU dev with a one year subscription recently, and the main reason was that I wanted to benefit from the QA plugin and the Forums plugin. To be honest, I'm very disappointed and I'm not satisfied at all, where the plugins I have tested are very simple and not sophisticated enough. Though I'm not here to complain, I'll pose my question:

Apparently the Forums plugin isn't compatible with any encoding other than ASCII. When I enter a forum name in Arabic, and save it, the saved name appear to be nothing but a set of Question marks rather than text! Why is this happening? Can I enable UTF-8 encoding? Or is the encoding irrelevant?

Another question beside this is: Can I get a refund and cancel my purchase?

Thank you in advance.

  • Vinod Dalvi

    Hi @Sam,

    Welcome to the WPMU Dev community and sorry to hear of the problems your having.

    where the plugins I have tested are very simple and not sophisticated enough.

    Let us know which features do you need in the plugins to fulfill your requirements.

    Apparently the Forums plugin isn't compatible with any encoding other than ASCII. When I enter a forum name in Arabic, and save it, the saved name appear to be nothing but a set of Question marks rather than text! Why is this happening? Can I enable UTF-8 encoding? Or is the encoding irrelevant?

    I could reproduce the issue on my test site therefore i have notified the developer to fix it.

    In the meanwhile you can fix it by finding the wp_forums table in your database and change collation of forum_name field from latin1_swedish_ci to utf8_general_ci

    For the all refund and other billing related issues contact our billing and accounting department using the following form.
    https://premium.wpmudev.org/contact/

    Thank you for being a WPMU DEV member and have a great day!

    Best Regards,
    Vinod Dalvi