Free Initial Trial as part of Subscription?

Hi! I have the following subscription on the site: first, a free finite 14 day trial set in for $0.00 that has a level where user can see all the content. Then after those 14 days follows a monthly subscription that requires payment. Users say that their credit card gets charged as soon as they sign up. Is that how this really works or I am missing something in set up? I would not want, naturally, my users to be charged when they signed up for Free trial, but only after they complete it. Please let me know if you need more information from me. Thank you!
Anna

  • Vinod Dalvi

    Hi Anna,

    I hope you are well today and thank you for your question.

    Is that how this really works or I am missing something in set up?

    No this is not how it it should work, i think you may be missing some settings.

    Could you please share me the screenshots of your Free Membership Access level settings and Membership General Options settings so that i can troubleshoot it or would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi Anna,

    Thank you for granting us support staff access.

    I logged in to your site and it seems the Membership plugin settings are correct.

    I could confirm the issue on your site by subscribing to the Free Trial membership as displayed in the attached screenshots. I can see you are using Authorize.net gateway.

    I have notified the plugin developer to get his valuable reply regarding this to know whether i have missed anything to check.

    He will reply here ASAP but our plugin developers have a lot of responsibilities so this might take a bit longer than a normal ticket.

    Thanks,
    Vinod Dalvi

  • robext

    Hi, I would like to see if we have any word on this? It has been some time, and I have other weird issues with the plugin (alas), would love to see if they may also be connected to this issue?
    Additional problem: When I enter a coupon for a full amount of, let's say, annual membership and give the code to the client, and the client enters it, the value does not go to $0.00, instead the client is taken to the page where the client must enter payment details. Is that how the plugin is supposed to work or no? The client still has to enter payment details even with the coupon?
    Thank you
    Anna

  • Michelle Shull

    Hi, Anna!

    Users shouldn't have to enter payment information for a $0 charge, you're correct.

    Would you mind doing a little troubleshooting? I see where Vinod asked the dev for some feedback, but let's see if we can track this down anyway.
    1. Let's try turning off all your other plugins. Switch to the sandbox credentials for Authorize.net while you run your tests, so no charges are sent.
    2. Log out of your account, and try to purchase a membership as a new user. Check the settings in your Authorize sandbox account to see if a "payment" (fake, since this is sandbox mode) goes through. If not, and it seems like the trial is working, we've narrowed it down to two possible things; a plugin conflict or a problem with your Authorize settings. The last is unlikely, since payments are working, users are just being charged too soon, and asked for details when they don't need to give any.

    Turn your plugins back on, in batches or one-by-one, until you find the plugin that's interfering, if there is one.

    Thanks, Anna!

  • robext

    HI Michelle,

    thank you for your reply! I just want to confirm one thing - I did run a test a while back with all plugins but membership off, and I tried to sign up for the Free trial, and it took me to the page where I had to enter payment info. This is the issue that still persists, and this is my original issue that I contacted about. I have the Free trial set up per instructions given in one of the threads - first it is a free 14 day sub, then it goes into a monthly sub. This is the setup that Vinod examined and confirmed it was correct. He also confirmed that with such set up a client must not be taken to payment page after clicking on Free trial membership and signing up. If it is the same issue that you were discussing with me, then turning all the plugins off does not fix it. Please let me know... Thank you!
    Anna

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.