Free time is not showing on my page

Free time is not showing on my page at http://www.p3clubs.com/make-an-appointment/.

It was showing until I removed some of the shortcodes that were placed on the page automatically.

The page used to have this code and was working:
[app_my_appointments]
[app_services] [app_service_providers]
[app_schedule] [app_schedule add="1"]
[app_pagination step="2"]
[app_login]
[app_confirmation]
[app_paypal]

I changed it to this and it is no longer working:
[app_schedule ... worker="23"]
[app_pagination step="2"]
[app_confirmation]

This code is consistent with what is checked in the settings panel. For example, I unchecked the need to pay or login.

My working hours are set.

Thanks,

Cheryl

  • pxwm
    • WP Core Meltdown

    Hi @Cheryl

    Could you please confirm if you have a Service Provider created with an ID = "23"

    If you do i suggest you need to add the Services shortcode back into your appointment page: [app_services]

    Could you also confirm if you have the Working Hours set for the Service provider with the ID="23"

    Hope this helps
    Regards
    SteveB

  • Alexander
    • DEV MAN’s Mascot

    Hi @Cheryl,

    Thanks for the detailed question. Sorry you're having problems here. @pxwm has asked some good questions that might help pinpoint what the problem is.

    Another thought on this, if you're omitting the services shortcode, you will need to specify a service. You can either return the services shortcode, or specify a service in your [app_schedule] shortcode like this:

    [app_schedule service="1" worker="23"]

    Best regards

  • Cheryl
    • WPMU DEV Initiate

    Hi Steve,

    To confirm, I do have a Service Provider created with an ID = "23", and I have the Working Hours set for the Service provider with the ID="23".

    I added the [app_services] back in but it still doesn't show my free time. The calendar at http://www.p3clubs.com/make-an-appointment/?wcalendar=1377251772#app_schedule does distinguish between Busy and Not Possible, but it's not at all showing the correct working hours or my free time (green).

    I actually have only one worker. With just one worker, should I keep it simple and remove some variables that might be causing a problem? Should I delete myself as service provider and then would that cause the calendar to show the default business Working Hours? Is that simpler?

    I have this now on the page:
    [app_schedule service="1" worker="23"]
    [app_pagination step="2"]
    [app_confirmation]

    Thank you!

    Cheryl

  • pxwm
    • WP Core Meltdown

    Hi @Cheryl

    Many thanks for the update.

    Is it possible you could post all the settings for the following A+ Settings pages:-

    'Services' tab
    'Service Provider' tab
    'Working Hours' tab for 'no specific provider'
    'Working Hours' tab for your single 'Service provider'
    'General' tab

    And for completeness a copy of all the text in your 'Appointment' page with the page set to 'text'.
    I need this just to check for any erroneous code

    You may have to post these on separate posts due to size limits

    Regards
    SteveB

  • Cheryl
    • WPMU DEV Initiate

    Hey Steve,

    Thank you!

    Here is the code on the appointment page:
    <table>
    <tbody>
    <tr>
    <td>Make a chat or telephone coaching appointment with Dr. Cheryl Mathews. You do not need to use the entire 10 minutes. You will only be charged for the amount your use. Purchase time on the coaching page.</td>
    </tr>
    <tr>
    <td>[app_schedule service="1" worker="23"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_pagination step="2"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_confirmation]</td>
    </tr>
    </tbody>
    </table>

  • pxwm
    • WP Core Meltdown

    Hi @Cheryl

    Many thanks for the additional information.

    I've checked all your settings and could you please change the following:-

    In the 'Services' tab could you change the capacity setting from '1' to '0'
    And save the setting

    In the 'Working Hours' tab could you set the 'Work?' dropdown to 'No' for everyday just for the 'no specific provider'
    And save the setting

    Then try making an appointment

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Cheryl

    I've just checked the screenshots and they appear to be the same.

    Could you please confirm if you have posted the latest screenshots for the 'Services' tab and the 'Working Hours' tab for 'no specific provider'?

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Cheryl

    Sorry, I didn't see these at the top.

    I've used your settings in my demo site and it all seems to work and showed available time. However I did identify a potential problem with v1.3 where it appears to be working out the end time of the Working Hours incorrectly and deducting 4 hours.

    post refers: https://premium.wpmudev.org/forums/topic/appointments-doesnt-properly-handle-24-hour-sessions

    However you should be seeing some available times.

    The developer, @Vladislav, has just released a new release v1.3.1 to fix a number of bugs in v1.3 and you may wish to upload and try.

    As always suggest you take a backup of your site and database so yuo have an option to rollback.

    Please let me know how you get on

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Cheryl

    I would suggest the next step is to provide temporary access to your Wordpress dashboard as Admin so your life settings can be checked.

    Unfortunately I'm fully booked over the next few days.

    Hi @Alexander Rohmann - Any chance you could pick this up to check the site settings? If you can could you confirm with @Cheryl how best to send you the temporary admin login details.

    Hi @Cheryl - If @Alexander Rohmann can pick this up and you are happy to provide him temporary admin access then suggest you take a backup of your site and database before sending the temporary login details.

    Please DO NOT post login details on the forum.

    Regards
    SteveB

  • Alexander
    • DEV MAN’s Mascot

    Hi @Cheryl and @pxwm,

    We won't be able to login as this is a benefit for members on the Gold membership level.

    Looks like I've missed out on the screenshots would you mind reposting them?

    Also, can you try disabling the built in Appointments+ cache? The settings for this are at the bottom of the general tab. Perhaps this is affecting the settings from being applied.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.