FreeBSD Directory Structure

Hi

I've got a FreeBSD 6.4 server where I want to install WP 3.0 as an MU site

I want to make sure I ftp latest.tar.gz to the right folder. I'm assuming it should be my site's version of public_html and when the files are unpacked I'll have this:

public_html/wordpress/wp-admin/

because the command tar -xzvf latest.tar.gz will create those two additional directories

Is this ok? I read that having a directory called "wordpress" will interfere with MU function -- is that no longer the case with 3.0? or should I find a way to unpack to a different directory?

I want to use subdirectories instead of domains for the various users

thanks

John

  • darvishjo

    Aaron,

    Thanks for your reply! I'm not sure I understand. What I've seen (I've installed and removed WP a couple of times) is that when I unpack the file latest.tar.gz the folder wp-admin gets tacked on to the back of the one called wordpress, which gets tacked on to the back of the directory the .gz file is in. If it goes there, it will NOT be in the web root folder as you advise. So if I need to alter the behavior or the unpack command, that's another issue I don't understand about.

    The way I was seeing it before, if I unpack the .gz in the right directory, wp-admin will be put in the right place according to what the tar unpacker thinks. But where should I put latest.tar.gz when I unpack it? That was my question. Now I find myself wondering about the default unpack behavior.

    my server has this tree

    /usr/local/www/data-dist/musicman/

    musicman is the top level domain name, and I unpacked the .gz there once. Lately I've been thinking I should have put latest.tar.gz in the data-dist folder instead. If I did that, then I'd get this when I unpacked (default):
    /usr/local/www/data-dist/wordpress/wp-admin/

    Good or bad?

    Your suggestion about subdomains is something I'll try to learn about. It looks like I could set up subdomains in my DNS server.

    thanks

    John

  • drmike

    Welcome to one of the joys of open source software. While they push svn and the rest, they assume that you;re going to download locally first, unzip locally, and then upload to the server via ftp. Bugs the heck out of me.

    You need to remove the /wordpress/ from the directory structure:

    /usr/local/www/data-dist/musicman/wp-admin

    Best bet would be to unpack within a temp directory, cd into the wordpress directory and then move everything out to the /musicman directory.

  • darvishjo

    Thanks so much for that drmike! That "joy" would be fine with me if it were documented somewhere, but if it is I don't know where. On my system there is a wordpress port /usr/ports/www/wordpress
    After updating the ports tree when I do make install clean from /usr/ports/www/wordpress something new appears that looks like this:
    /usr/ports/www/wordpress/work/wordrpess/wp-admin
    That doesn't look like an "installation" to me so I've never tried to use it. It just looks like something that was unpacked -- again in the wrong place. If I moved everything into the musicman directory from the new wordpress directory that is produced by "make install clean", would that do the same thing? Just trying to make sense out of wordpress in the ports tree.

  • darvishjo

    My attempt to implement drmike's suggestion did not go well. I installed wp but could not access it because the link on the dashboard went to the previously existing index.html file in the root directory. I could not see how to make it use wordpress index.php instead so could not see the new blog.

    I found a page titled Giving WordPress its Own Directory in the codexes but at the bottom of that page it says "Please note, this procedure will not work in WordPress MU or in WordPress 3.0 with multisite enabled. It interferes with the member blog lookup." What I want is multisite with 3.0, so I can't fix the index file confusion by putting the index file I want to use in a different directory.

    Is this where the subdomain comes in?

    At this point I removed the new directories and files, intending to start over. When I went to remove the wordpress table in phpmyadmin, I discovered I had lost the ability to open the database there because I could not get past the "Authentication Required" panel. I have two usernames and passwords that work for the MySQL server on the command line, but no longer on phpmyadimin/login.php--so I went to the MySQL command line server and removed the wordpress table there.

    Final score: Attempt to create wordpress multisite failed; one additional functionality (phpmyadmin) lost. :slight_frown:

  • darvishjo

    After dropping my previous approach with the musicman top level domain, I went to another
    domain I have whose root directory is not so cluttered, although after installing the new blog it does have both and index.php and index.html

    the new domain is johnsart.biz; I've already unsuccessfully tried this another time, and sure enough i got the same failure this time when trying to access http://www.johnsart.biz/wp-admin/:

    "You don't have permission to access /wp-admin/ on this server."

    ls -lad wp-admin from the johnsart directory gets this:

    drwxr-xr-x 7 john wheel 2560

    When this happened before I tried many different ways of changing permissions, I put an override line in wp-config.php and a put a "disregard secure" line of some kind in the .htaccess file (suggestion found on the web), and there was also a whitelist rule that I tried to disable in the httpd.conf vhosts containers, but nothing I tired succeeded.

  • darvishjo

    OK phpmyadmin is back again and I've removed the old wordpress table then put in a new one, ready to start over

    I found this at http://wpbandit.com/tutorials/install-upgrade-wordpress-svn/

    ********
    To install WordPress using Subversion you would execute the following command from the shell of your web host, replacing version with the actual version you are installing:

    svn co http://core.svn.wordpress.org/tags/version .
    To install the latest version, 2.8.4, you would do the following:

    svn co http://core.svn.wordpress.org/tags/2.8.4 .
    When executing this command make sure that you are in your website’s root directory (normally public_html or www) or the directory that you would like to install WordPress in. Afterwards, finish the installation as you normally would by editing your wp-config.php file and running the WordPress installation script.
    *******

    I installed subversion with the ports tree, so I could theoretically do this, but what will happen if I do it while I am in my website's root directory (/usr/local/www/data-dist/ vs. when I'm in one of the domain directories for example /usr/local/www/data-dist/musicman? If I do it from the musicman directory will I have the same index file conflict I described earlier?

    I suppose I could just try it and see but I'll wait a while first

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.