Fresh download already out of date

Hi,

I have just downloaded the 'recents posts' plugin 1.0.1 showed as compatible with the very latest version of wordpress. Once installed, I got notification the plugin has a new version. wow very fast, so I look at the details and effectively there were an updated version 1.2 178 days ago ! So, how the so fresh version of the website is not even the last one from half a year ago ?

So, I decide to automatic update and then I get ftp connection to nowhere. What is le host/login/password to use ?

Stephane,
new to wpmudev, quite confuse about how it's difficult to use premium plugins