Friends, friend reqeusts and messaging don't work irrespective of theme

Hi

I am running BP 1.7.1 and WP 3.5.1 have a theme (ProjectTheme by sitemile) with a child theme (Bounce by ghostpool). I had a developer help me set up this. I am not a developer and am a steep learning curve due to a small budget (read: can’t afford a developer at this point).

My problem is that no matter what theme I run (also WPMU themes like Network and Studio) I can make friend requests and receive both mail and WP toolbar notifications that I have a friend request, but when I try to accept I get 404 error. I have no way of accepting outside of the toobar, i.e. no page.

I have tried to figure out how to create a friends page and requests page, but it is beyond my skills. When I look on the FTP I can see that all the .php templates are there. When I look at page attributes and try to choose a template from the drop down I get the following options (I have put what I believe to be the controlling component in brackets): Default (bounce), Blank page (bounce theme), BuddyPress activity directory (BP), Login (WP), Page list (?) and project_special_page (project theme).

Irrespective of which theme I choose (including BP theme) I can not get friends or request pages to work.

How do I fix it? Do I need to create friends and request pages or should they generate automatically? Why are there .php templates, but they don’t show up in the page attributes template list and if I wanted them to show up there how do I do that?

I realise that these are not necessarily easy questions to answer in a post, but if someone can point me in the right direction via documentation or similar, I would appreciate it.

Regards
Jason

  • aecnu

    Greetings Jason,

    Sorry to see that you are having an issue with your WordPress installation and the Membership plugin

    What Friends are you referring to? That which is native to BuddyPress or is it the WPMU DEV Friends plugin?

    Have you tried resetting the permalinks by any chance? You do not necessary have to change them unless they are set as default - then they need to be changed.

    If no change is necessary then be sure to click "save changes" anyway which will indeed reset them.

    Test again.

    Are you running caching on the WordPress installation in question by any chance?

    Are you using two completely different browsers for developing and testing? i.e. Firefox for developing and Chrome for testing and dumping the caching and cookies of the test browser before each test?

    Please advise.

    Cheers, Joe

  • jason_lorje

    Hi Joe

    First of all you guys are fantastic, I always get a rapid response from you. As I said in my first post. I am very green at all this and learning by doing, so I may have skipped some basics.

    To your questions:
    I am talking about native buddypress that I am having troubles with. No matter what theme I use I don't get friends and/or friend request pages. I get forum, activity, groups directory pages via my theme, but friends, profile and other pages don't come up. I can't figure out if it is because I haven't defined them or what's happening.

    Permalink settings are set to numeric in 'common' options. I have not set any 'optional' settings, frankly because I don't know how I should use them.

    Regards caching: Please excuse my ignorance. How would I find out if Wordpress was caching?

    I am not using two browsers, only Chrome. From your comment I can see that it would be an advantage to use two.

    If it helps you can go in via a dummy profile I have set up. beetoobee.net; Username: Test; Pw: Haldal84.

    Regards Jason