Front end does not run over https

Hi Support,

My newly created pro site's front end does not redirect over https but the back end does.

Can you please help?

Regards,
Jimmy

  • Adam Czajczyk

    Hello Jimmy,

    I hope you're well today and thank you for your question!

    I understand that the issue here is that when you signup for a new site with Pro Sites, that newly created site is available via "http://" connection and not redirected to "https://" while its back-end goes over SSL, is that correct?

    I checked your main site and I see that it's redirecting to https:// when accessed via http:// or without protocol prefix but can you tell me please how this is set up? I mean: is this some kind of CDN or .htaccess redirect (or via a plugin) or is the site configured with https:// address "natively"?

    Would you mind granting me a support access to your setup so I could take a closer look at that and examine the case? In order to do so, please follow this guide and let me know when it's ready:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Jimmy

    Hi Adam,

    Yes, when I created a new site and changed the new site's url from http to https in the admin panel the new site's front end does not run over https, instead is redirects back to http. But when I log into the new site's wordpress panel the site's url starts with https. I have a multi domain ssl sertificate installed on server and as the back end of new site runs fine over the ssl it must mean the ssl certificate is active for this domain.

    The main site's url gets redirected to https through the rewrite rule set in the .htaccess file.

    I have now grant you access to my admin panel.

    Hope hou can help.

    Thanks
    Jimmy

  • Predrag Dubajic

    Hi Jimmy,

    Thanks for granting access, I had a look at your site and performed couple of tests, it looks like this issue is not related to Pro Sites as it's happening both with non-pro sites and even when the plugin is completely disabled.

    It seems like this is something on server end where SSL certificate is not properly configured for subdomain multisite installation.

    I would suggest getting in touch with your server provider in order to check your SSL cert and make sure first that everything is properly configured there.

    Best regards,
    Predrag