Frustrated with Directory Setup

I have the latest version 2.0.2 installed. I have CustomPress installed. I know that the instructions for the plug-in have not been updated since the new version was released.

Some direction on how to configure this plug-in would be greatly appreciated. I have not been able to make any use of it unless I use the included plug-in. I cannot get to a signup page or anything other than the main page with a list of all the categories I created. (list of States)

When I try to add a new listing I am taken to the Wordpress post screen. I don't believe that is how it is supposed to work. No one is going to know how to enter a listing or what to do. I am trying to use it with iThemes Builder but have also tried with TwentyEleven to no avail.

I see all the custom post types and loop direction code in the folder of the included old theme. How is any of that supposed to be used if we are not using the old theme? In the configuration for CustomPress I have no custom post types, no taxonomies and no custom fields. I'm a little frustrated and would appreciate some direction.

    aecnu

    Greetings prestonkd,

    Thank you for being a WPMU Dev member!

    I have not been able to make any use of it unless I use the included plug-in.

    Please clarify, perhaps you mean the included theme?

    I have not had any problem making this work, but I am using the included theme.

    However, I do have a post where a member tells how it is done which many others have followed with success:
    https://premium.wpmudev.org/forums/topic/directory-child-themes-a-tutorial

    In addition, if you take a peek on the following link, in the instructions there are some details about embed codes:

    https://premium.wpmudev.org/project/wordpress-directory/installation/

    You can use those to embed the data where you wish within your own theme. You could also take a peek at the current Directory theme which comes packaged with the plugin, that should give you a head start on the functions you need to embed into your own theme.

    Hopefully this will help you produce what you want to design.

    Alternatively, you could see if there's a developer available at wpmu jobs who could get onto it right this minute, but we're aiming to get you sorted ourselves.

    Thanks again for being a WPMU Dev member!

    Cheers, Joe

    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    prestonkd

    Thanks for your response. This plug-in has just been completely rewritten. The screens and options for importing taxonomies and such no longer exist. The plug-in is now meant to be used with other themes than the included theme and in addition, the CustomPress plug-in. I have seen Andrey post about writing a new set of instructions. I had no problem using the previous version. Try using this with a different theme and you will see what I am talking about.

    aecnu

    Greetings prestonkd,

    After a brief discussion with Andrey regarding the Directory plugin and the newer version - based upon your statement I had no problem using the previous version I recommend that you roll it back to the previous version that you were happy with using.

    It also appears that there has been yet another update 2.0.3 since you had originally submitted this ticket, but I think your main concerns here are not addressed in the update.

    Please advise if you are able to satisfactorily able to return to the previous version that you mentioned that you liked and had no problems with.

    Cheers, Joe

    prestonkd

    Thanks Joe. I'm sure I could revert to the previous version if I chose to do so. I don't really have any interest in doing that because I would have to use the included theme. I'm actually pretty close to having the new one working. I just have a couple of things to work out and I may have it. Problem is that although I am pretty good at figuring things out and using stuff like this - I am NOT a coder or programmer although I dabble at it - meaning that I understand a lot of the terminology and BASIC theory but not much more.

    If someone could tell me how or where to edit the directory_listing custom post type that Directory uses or how to make the Directory plug-in use a different custom post type that I create in CustomPress that would solve one of my main problems. The other is to get the information to display in a grid form like it does with the included theme. But I think I can actually figure that one out if I can edit that directory_listing thing so it doesn't show the content box and only shows my custom fields. If you or Andrey or anyone else can offer any guidance on that it would be appreciated. Thanks.

    aecnu

    Greetings prestonkd,

    OK so we have clarification of what you want to do and what the primary problems are holding up that mission:

    a) How or where to edit the directory_listing custom post type?

    b) How to edit that directory_listing thing so it doesn't show the content box and only shows my custom fields?

    If I knew which theme you were using I would possibly be able figure out how to get rid of the content box - could you please give me a screen shot of the content box you want to remove and the name of the theme? Or am I missing something here?

    I will see if I can get Andrey in here to answer these two questions asap so that we may get you going again.

    Cheers, Joe

    prestonkd

    Joe:
    I have attached a screenshot of the page I get when I add a new listing. I am using iThemes Builder. There is no styling, customization, information or anything on the site other than the unaffected base theme right now.

    I have made the content box as small as I can but you still see it there above the fields where people would enter their name, address, etc. There is no reason for the content box to be there for my site and I need to get rid of it. If I leave it there people are going to feel like they are supposed to write something in it. If they do, it is going to mess up the listings.

    It seems to me that in order to do this I will have to either 1) be able to edit the directory_listing custom post type or 2) get the Directory plug-in to use a custom post type that I create in CustomPress. It seems like there would be other people that would not want that content box there. There may even be some way that is already built in to the plug-in that I am just not seeing. Thanks for your help.

    prestonkd

    Thanks Andrey. I am really looking forward to using your plug-in! I know that you have put a lot of work into it and want it to work right and people be able to use it.

    From my original question above - I have resolved several of the issues. I can now see the sign-up page. The issue was that it will not let me see it if I am logged in. Instead it was just taking me to the homepage. If I am logged out and click the sign-up button, it works properly. So that is no longer an issue. I have found how to create the custom fields and such in CustomPress so that is no longer an issue.

    To my knowledge at this point the only issues that remain are first, being able to either 1) edit the directory_listing custom post type or 2) specify a new custom post type for the plug-in to use then secondly to have it display in a grid like the original theme did instead of just down the left hand side of the page. That second one is not a huge deal and I think I might actually be able to do that one with a plug-in I have called LoopBuddy. So really its mainly just the directory_listing thing that is keeping me form being able to use it.

    Thanks again for your assistance. Sorry if I have sounded a little too frustrated. I don't mean that to come down hard on you. I am as frustrated with myself for not being able to figure it out as I am with the plug-in.

    ginnydeering

    Great to hear that there have been some improvements on this product. I tried to use it several months ago and just abandoned my efforts because I ran out of time. I'd like to revisit the directory, since I paid for it and spent about a week getting it to work. Are there some good instructions on how to incorporate this into an existing theme? How about customizing the css?

    Thanks,
    Ginny

    prestonkd

    Ginny:

    The plug-in has been rewritten as a stand alone plug-in where you can use it with whatever theme you are already using. I would expect that as with all thIngs, some themes will play with it better than others. I have not experienced any theme related issues. You will have to do your CSS outside of the plug-in if you are using your own theme. I have the ability to do all of my styling independently through either my theme or CSS so that's fine. My issues have all been related to custom fields and custom post types. Hopefully that will all get worked out soon.

    jloweezy

    I have almost gotten my Custom Fields to work within my Directory... have experienced many of the same frustrations as Preston and Ginny. I downloaded CustomPress to help me - and I understand just about everything except for this:

    "Simply copy the embed code and place it inside your WordPress loop to display the new custom field with your theme"

    Um, what? I don't seem to have access through the suggested route of Appearance>Editor as this does not show up as an option. I can get to the code, can copy and paste it, but I have no idea where to paste it.

    Janet

    lorgra

    I'm having the same problem Janet is - I've installed and configured both Directory and CustomPress plugins, and have the custompress custom fields showing up on the Directory creation pages, but not on the front of the directory listing. Like Janet, I can't figure out where to put the embed code for the custom fields - I can't find the template file that the Directory is using for the listing page (I'm not using the included theme for my site overall, because the directory is only one section of my site).

    And per prestonkd's request I'd also like to be able to prevent the main context box from showing at all.

    Any help pointing me in the right direction would be great. Thanks!

    gsheldon

    I've just revisited this plugin, and sadly, I still cannot get the latest version 2.0.4 to work. I've tried several different methods, all on a fresh, nothing added version of WordPress. I installed nothing else and activated no other plugin, and it doesn't work. I started another new WordPress site, no other plugins, and installed 1.07, then updated to 2.0.4., and it didn't work.

    I had two projects where I wanted to use it, but I walked away from the Directory plugin because of time constraints.

    I do hope this works out - but at this point, without updated installation instructions and/or fixes, it just doesn't seem to be working properly.

    aecnu

    Greetings Everyone,

    I do not know what is going on here but I got it to work first crack.

    http://bulgariannet.easystartdiywebsitedesign.com/listings-category/restaurants/

    I admit the text is out of line in which I will tell the developer about, but it works just fine to the best of my knowledge.

    I am using the supplied theme in this demonstration.

    Below is a screen shot of the site admin panel and shows that is it managed under listing.

    Note: this plugin does not work with Buddy Press!

    I hope this helps.

    Cheers, Joe

    prestonkd

    You are using the supplied theme. We are all trying to use the plug-in with our own theme. Also, it looks like from your example that you entered your text In the content box. Myself and others are trying to have listings where people have entered their name, address, phone number, etc., not just displaying text.

    Try using a different theme. Create some custom fields for name, address, etc. then go to the add listing page. You will see your custom fields below the content box. You will not be able to get rid of the content box. If you have created and named all of your custom fields for your needs, you will have no need for a blank content box. Of course if it was us going to the site to create a listing we would know to just ignore it. Other people that go to the site will just be filling in a form. If there is a blank content box they will feel compelled to put something in it. Do this and you will see what all of us are talking about. You are not comparing apples to apples. Andrey has responded here and apparently understands the issue and is going to provide a solution. The whole point of the new version is to not have to use it with the supplied theme.

    aecnu

    Greetings prestonkd,

    Actually my post was not directly relative to your issue with the plugin, it was meant to address those that claim it does not work and my apology for not clarifying that it applies to them.

    I am clearly not trying to use it with another theme nor did I set out to do so. But I did prove that beyond a shadow of a doubt it does work with its supplied theme.

    I am very aware that Andrey came in on this - I brought him in directly in our direct talk between the two of us (Andrey and I) on Friday about your issue and the others issues dealing with themes outside of the Directory plugin

    Cheers, Joe

    jloweezy

    I'm late in responding - but I finally got frustrated enough to just deactivate the Custom Press and see how it goes with the blank content box. For now, it's less headache than trying to figure it all out.

    For the record, I did finally (with help from Timothy) get the embed code put in the right place for the Custom Fields to show up on the screen. But, for now, I've got enough headaches trying to make it all work... just tonight the Sign-up page is now returning an error. But that's going to be saved for a NEW support post since it isn't really all that relevant on this one.

    Thanks to everyone for being so willing to help figure this out. I'm pretty certain when it gets running as well as we expect, that we're all going to be THRILLED!

    Thanks!

    Janet

    jloweezy

    With the theme I was using, the file was either singlepost.php or singlepage.php or it might have even been the loop-page.php. The problem I then ran into was that even on pages that weren't Directory related, the custom fields were showing up at the bottom. I finally got frustrated enough to deactivate CustomPress across the network.

    One suggestion - if you know what type of content you are creating - for posts, pages, taxonomies, etc. then you go into your theme editor and find the associated .php file. I hope that helps a little bit. I'm certain that someone with a bit more experience and knowledge than I have would be able to assist you, as I'm scrambling along trying to follow instructions and make do without having to pay someone to come and build a site for me.

    prestonkd

    Joe and Andrey:

    I have updated CustomPress and Directory. The ability to edit the directory_listing custom post type in CustomPress is appreciated and works great. I had actually found the code where that content box was included a few days ago and got rid of it but it is much easier to deal with now. Thanks to you both for recognizing and dealing with this problem.

    I am still in the process of putting my site together so I don't know if I'll run into anything else. The only thing I have seen so far is that after a signup when the user is taken to a page that says they have signed up successfully and gives them the choice of going to their profile or creating a listing. If you choose "Add Listing" it takes to you a "cannot be found" page that ends in "/add-listing". I solved this by using a redirect plug-in that goes to the correct page. I found the code that produces "add listing" but could not find where to change the url that it took you to. I'd like to not have to use the redirection but it is not a deal breaker right now.

    My initial problems that caused me to start this thread have been resolved. I can start another thread about a specific issue if I need to. Thanks for the assistance.

    aecnu

    Greetings prestonkd,

    Thank you for the feedback, it is certainly appreciated.

    I tested this out with the new version and found that when logged in and choosing the Add Listing I do not get anything what-so-ever, not even a 404.

    Therefore I confirm this new bug in the Directory plugin - so you are certainly doing better then I am.

    I will let Andrey know asap.

    I did not try to work with a redirect due to not wanting to have to undo the redirect when testing this again in the near future - I want to see the exact result folks using the plugin see.

    Cheers, Joe

    prestonkd

    The new version 2.0.5 did not fix the issue for me. Also, the new version did not show up in auto-update. I had to delete the plug-in and upload it fresh. The "add listing" button I am talking about is not the one that is on the main page. It is the one that only appears on the successful sign-up page with the option of either creating a listing or going to the users profile. I have attached a screenshot of what I get if I choose to add a listing. For now, I have just reactivated the redirection plug-in. I would like to know if it is now working for others or if everyone has the same issue.

    aecnu

    Greetings everyone,

    Directory plugin update straight from the brand new lead developers desk - I am building it up from the bottom due to it depends a lot on CustomPress so I've redone a lot of Custom press things and still working at a polished product to come out in the near future.

    Yes Arnold thank you for that update - I do not know about the rest of you folks but I have noticed that during the last Custom Press plugin update users were delighted.

    In addition, taken directly from the Custom Press change log for version 1.2 which was the last version update I present this fact: Compatibility with the Directory plugin

    Therefore it is moving forward slowly but surely and I am sure all of us look forward to the long anticipated replacement so to speak of the Directory plugin.

    Thank you all for your patience.

    Cheers, Joe

    neuroticartist

    OMG this thread makes my head spin. I purchased the 1.x version of Directory for a client project because it had everything I wanted, cept when I bought it, it wasn't really a plug in, it was its own theme,

    So I paid someone to try to embed the code into my theme, which was another expensive nightmare. so I patiently waited (keeping my client at bay for months) till the 2.x version came out, which really IS a plugin. problem is, almost NOTHING about the original version is included. now 6 months in, Im still trying to get it working. I need BuddyPress now too?

    After reading this particular thread, Im really wondering if waiting around for new updates is even worth it, or should I just drop the entire thing and seek out a different Directory plugin. I was so excited to see the new version, but my heart sank when I realized it doesn't work at all like the first version, which is useless if I want to use it in a different theme. How much money and time Ive wasted because of this? lots.

    Just a rant, theres no questions involved here other than why did I waste 6 months and several hundred $.

    *SIGH*

    aecnu

    Greetings neuroticartist,

    I need BuddyPress now too?

    I have no idea where you got the idea that you would need Buddy Press?

    Actually I stay away from Buddy Press myself due to the bugs they had in version 1.54 made it miserable to try to debug not knowing they had so many bugs and then when they came out with version 1.55 many of the problem we were having with Buddy Press installs I admit went away, but just too d-a-r-n much to integrate and so many people were blaming us when it was in fact Buddy Press itself, but the silence as incredible with the lack of apologies from those slamming us and found out in the end it was indeed Buddy Press - but that is a different story and end of my rant about Buddy Press ..... lol ..... oh one last thing, when trying out Buddy press and activating it and then deactivating it don't be surprised that your database gets hosed:
    https://premium.wpmudev.org/forums/topic/comments-and-replies-go-missing#post-201295

    I was so excited to see the new version, but my heart sank when I realized it doesn't work at all like the first version, which is useless if I want to use it in a different theme.

    That is the whole idea of the new version, is to make it so it will work with almost any theme. However, if in fact you liked the old version better or it was/is working for you then of course revert back, the downloads of previous editions are available in the download area.

    Having said all that if any of you guys (or ladies) that have successfully programmed everything needed to make the v2.x work correctly from sign up to end user additions and reviews, Im willing to pay for the help

    You may want to also see if there's a developer available at wpmu jobs who could get onto it right this minute, but we're aiming to get you sorted ourselves with our new developer, and yes this exact mess from Directory plugin cost the previous developer his long standing job with WPMU Dev for any of those interested in knowing.

    I can hardly wait to see the next version that the new developer Arnold comes out with ....

    Cheers, Joe

    neuroticartist

    Reading these posts, it seems like I need additional plugins to configure a user page where they can enter all the info to post a listing in Directory, I havent even got that far yet in my attempts to customize this and make it work (after 4 months of frustration). Reading how extensive one needs to add and configure something for that part kind of makes my head spin after all Ive been through already.

    Unfortunately regarding the original version, I have never needed a theme, only a plugin, I have an extensive theme already built that I was wanting to build this plugin into, so going back to 1.x was never an option as it wasn't an option when I purchased it. Using its own theme was never something I expected, it was sold as a Plugin not a theme on the site.

    Ive posted on the jobs area but didn't get any replies except from site designers in India that browse every possible website looking for gigs. I would, however, gladly accept help from someone who was recently in the same boat as I am, and has successfully figured out how to get this plugin working on a custom theme.

    I appreciate that you guys got a new developer, Ive talked to him on a couple other posts, but his repeated use of the therm "Inherited this theme" doesn't do much to garner any kind of excitement, it sounds as though he wasn't too happy about it either

    prestonkd

    This plug-in as it stands is a train wreck. I don't think it is possible to use it in any effective way. It is so unstable I would not want to use even if someone could get it working. It is one of those situations where you fix one thing and something else breaks. I am currently working on putting my own together using CustomPress and Gravity Forms. I will use that and then compare it to what the new developer comes up with. Personally, I think they should remove the current plug-in and just say "coming soon". I have not heard of anyone who is happy with the current version. It is put together in such a "duct tape" manner that I can't imagine it being compatible with the new version or upgradeable . Those are just my opinions and are worth what you paid for them - unlike this particular plug-in.I

    prestonkd

    Thanks Joe. I must say though, that is not the least bit surprising. I might even add a "told you so" but that would serve little purpose. I would like to forward a word of encouragement to the new developer. Thanks for recognizing and calling this plugin what it is, "flawed". I for one would greatly appreciate you taking as long as it takes to make this thing work right. Myself and anyone who had tried to use this thing realizes that that will mean starting from scratch. Looking forward to what you come up with.

    aecnu

    Greetings prestonkd,

    You are absolutely correct that he see's the flaws within to say the least and as he indicated in another post that he has to start with Custom Press plugin and work his way forward to the Directory plugin because the mix and match between the two plugins has caused a lot of the grief all of us have that have tried to use this plugin in the past experienced.

    Have anyone noticed that, what certainly seems weekly, there have been fixes made by by our new developer to Custom Press?

    This is in partial advanced preparation for the re-integration of the new version of Directory plugin in which we are all in great anticipation to see.

    Cheers, Joe

    aecnu

    Greetings,

    Just a heads up to everyone that now that our new lead developer of Directory plugin as well as the related Custom Press plugin has almost got Custom Press completely in hand to include the also related Classifieds plugin, he is now knee deep into the Directory plugin and is reportedly a couple of weeks or so away from his first release of the Directory plugin in which I am sure we are all in great anticipation thereof.

    Cheers, Joe