Frustrated with Domain Mapping in Plesk

Hitting the wall trying to get domain mapping working with Plesk. The main domain is lcbmultisite.com. Subsite is lcbtestsite.com.

My wp-config file:

/* Multisite */
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'lcbmultisite.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

define( 'SUNRISE', 'on' );

I've tried to follow directions from here:
http://codex.wordpress.org/Configuring_Wildcard_Subdomains_for_multi_site_under_Plesk_Control_Panel

I don't care about email, so all I have done in Plesk is create a file at /var/www/vhosts/lcbmultisite.com/conf/vhost.conf with the following:

ServerAlias "*.lcbmultisite.com"
ServerAlias *.lcbmultisite.com

In the DNS settings in Plesk for lcbmultisite.com, I've added this CNAME record:
*.lcbmultisite.com. CNAME lcbtestsite.com.

Not working (shows as Invalid and navigating to the domain gets a server default page).

Thoughts? Thanks…

  • Vaughan

    Hi Bert,

    Hope you're well?

    First things first :slight_smile:

    If I type in your sites IP address in my browser, I receive a default plesk server page.

    You must make sure that your multisite domain has a dedicated/static IP.

    Secondly, The IP must be pointing at your multisites documentRoot, so when you enter the ip address in a browser, you should see the front page of your multisite and not a default server page.

    Domain mapping will not work with A records until that issue is solved, You may need to ask your host about that.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.