FTP/SFTP from Snapshot PRO

Just setup Snapshot PRO for one of my sites (in progress of doing all of them) and I have a question. I set the destination directory as described in the snapshot setup and it verified as correct. So I did the first snapshot, which ran successfully, but when the SFTP ran, it connected fine, changed to the directory in the settings and, for some reason, tried to do a mkdir over top of it (failed). Good news is it did the PUT to the root directory so it did get here. So, what do I need to do to make it go where it is supposed to be? FYI - it is a mounted external drive, the destination is a Debian/Linux box, and I doubled checked that it was mounted and had the correct file permissions for the user. Log is below:

2016-08-03 17:36:49: finish: snapshot-1470260133-160803-213533-d7d0262d.zip
2016-08-03 17:40:55: Sending Archive: snapshot-1470260133-160803-213533-d7d0262d.zip 26.32M
2016-08-03 17:40:55: Destination: ftp: Home
2016-08-03 17:41:09: Using sFTP connection
2016-08-03 17:41:09: Connecting to host: *************** Port: 22 Timeout: 90
2016-08-03 17:41:09: Login success.
2016-08-03 17:41:09: Home/Root: /home/****/
2016-08-03 17:41:09: Changing Directory: /mnt/*****/LiquidWeb-WPMUDEV-Snapshots
2016-08-03 17:41:09: sFTP: Failed to MKDIR: /mnt/*****/LiquidWeb-WPMUDEV-Snapshots
2016-08-03 17:41:09: PUT file success: snapshot-1470260133-160803-213533-d7d0262d.zip



  • Jim
    • Design Lord, Child of Thor

    Additional - I tried to add an extra node to the directory to mark which of the 30+ WP sites I maintain. That did not work as well (I had created before running the snapshot.

    I also tried to send it to the actual Linux box on the /home drive and it again dropped to file in the user root directory.

    2016-08-03 20:36:28: Home/Root: /home/jim/
    2016-08-03 20:36:28: Changing Directory: /home/jim/WPMUbackups/djoalumni
    2016-08-03 20:36:28: sFTP: Failed to MKDIR: /home/jim/WPMUbackups/djoalumni
    2016-08-03 20:36:28: PUT file success: snapshot-1470260469-160804-003608-5545ee9f.zip


  • Adam Czajczyk
    • Support Gorilla

    Hello Jim,

    I hope you're well today and thank you for your question!

    I understand that you run your own server(s) and are in a full control of it, is that correct? Could you please - just for testing purposes - check whether this works well over a regular FTP connection (not SFTP)?

    I'd just like to find out if it's related to a "transport", to the destination or to the Snapshot's code.

    Let me know please what you found.

    Best regards,

  • Jim
    • Design Lord, Child of Thor

    Adam Czajczyk -

    Works 100% with ftp.

    2016-08-03 22:24:10: Using FTP connection
    2016-08-03 22:24:10: Connecting to host: ***************** Port: 21 Timeout: 90
    2016-08-03 22:24:10: Passive mode off.
    2016-08-03 22:24:10: Timeout set to 90
    2016-08-03 22:24:10: Login success.
    2016-08-03 22:24:10: Home/Root: /home/jim
    2016-08-03 22:24:10: Changing Directory: /home/jim/WPMUbackups/djoalumni
    2016-08-03 22:24:10: Current Directory: /home/jim/WPMUbackups/djoalumni
    2016-08-03 22:24:10: ftp_put success:snapshot-1470260469-160804-022359-87c4d210.zip

    So, ftp works as a stopgap measure. Let me know if there is further info I can supply to the developer team to hasten an SFTP solution. :grinning:


  • Predrag Dubajic
    • Support

    Hi Jim,

    Could you try temporary setting "LiquidWeb-WPMUDEV-Snapshots" folder permissions to 777 just so we can see if there's permission issue or there's something else causing it?

    Let us know how it goes :slight_smile:

    And thanks for opening separate thread for other questions, it helps keeping track of everything :slight_smile:

    In the meantime I have forwarded this issue to our developers so they can check the code directly and see why this is happening on sFTP connection while FTP works fine.

    Best regards,

  • Jim
    • Design Lord, Child of Thor

    Hi Predrag Dubajic -

    I just ran an sFTP test, changing the destination directory with permissions of 777.

    drwxrwxrwx 3 jim jim 4096 Aug 3 22:47 snapshots

    I still get the same results:

    2016-08-04 12:40:54: Login success.
    2016-08-04 12:40:54: Home/Root: /home/jim/
    2016-08-04 12:40:54: Changing Directory: /home/jim/snapshots
    2016-08-04 12:40:54: sFTP: Failed to MKDIR: /home/jim/snapshots
    2016-08-04 12:40:54: PUT file success: snapshot-1470328595-160804-163635-b33f3426.zip

    It connects fine, finds the directory, then attempts to do a mkdir which fails (already there), and then PUTs the file in the user's root. I notice that the difference between the simple FTP and sFTP is that it appears in both the find the directory, but the sFTP insists upon doing a mkdir.

    Also, using the mounted external drive (/mnt...), the only subdirectory permission available is 755 (limits to the proper user only for write).

    Hope this helps!


    PS: All the snapshots I have configured so far using simple FTP work perfectly.

  • Dimitris
    • Support Star

    Hey there Jim,

    hope you're having a beautiful day and don't mind skipping in! :slight_smile:

    I can already see in our bug tracker that this is confirmed bug from Predrag and another developer of ours. :slight_smile:
    SFTP connections always do mkdir and try creating folder even if it exists.

    Hopefully this will resolve soon enough in a bugfix release. Just keep an eye on this thread or for any updates through your WPMU DEV Dashboard or Hub, and we'll keep you posted as soon as we've got any update.

    Kind regards,

  • Jim
    • Design Lord, Child of Thor

    Hopefully this will resolve soon enough in a bugfix release. Just keep an eye on this thread or for any updates through your WPMU DEV Dashboard or Hub, and we'll keep you posted as soon as we've got any update.

    So, any progress?

  • Adam Czajczyk
    • Support Gorilla

    Hello Jim!

    I'm sorry for keeping you waiting.

    The recent Snapshot Pro release included some fixes related to connection protocols but it seems this particular issue turned out to be a bit more complex than expected and it's still being worked on. I can see that some initial fixes has already been commited but there are related (resulting) issues that needs to be addressed as well.

    I appreciate your patience on this and I hope we'll get it solved soon. I already asked one of the developers what's the status of this.

    Best regards,

  • Adam Czajczyk
    • Support Gorilla

    Hello Jim!

    I just got a word from one of the developers involved and the good news is that he applied a patch already to the code. It wasn't yet released to the public because it still needs some testing (including that patch) and I still can't give you an ETA but at least I can confirm that it's been already taken care of.

    That being said, please keep an eye on your site's dashboard and make sure that you update the Snapshot Pro as soon as next release goes out and - though I still cannot confirm that for sure - I think it will most likely include that patch.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.