fundraising error message "oh no..."

Oh No, we can't find your Pledge. Sometimes it take a few moments for your Pledge to be logged. You can try refreshing this page

I am getting this error message also and the fundraising bar is not getting updated, but Paypal is showing that funds are being transferred. My cpanel is not showing any errors. I am using the fundraiser plugin on dough.imadeitfromscratch.org and I have this url in my paypal IPN:
http://dough.imadeitfromscratch.org/wp-admin/admin-ajax.php?action=wdf-ipn-return-paypal

Here's the Paypal IPN log message:

Donation Received (Unique Transaction ID #0LM818316A407761L)

Name:
daniel ziskin (The sender of this payment is Verified)
Email:
ziskin@jote.org
Payment Sent to:

imifs@imadeitfromscratch.org

Total amount:
$1.00 USD
Fee amount:
-$0.33 USD
Net amount:
$0.67 USD

Issue a refund Help

You have up to 60 days to refund the payment.

Donation Amount:
$1.00 USD

Purpose:
Creating the App
Custom:
11||25278bb8a94d||7||0||3995 darley ave||||boulder||CO||80305.
Date:
Oct 27, 2014
Time:
11:32:41 PDT
Status:
Completed

Mailing Address:
No Address Provided

Payments without a shipping address are not covered by PayPal's seller protection policies and programs. Learn More

Payment Type:
Instant

Description:
daniel ziskin

Here are some lines from the access log:

173.0.81.1 - - [26/Oct/2014:17:51:03 -0400] "POST /wp-admin/admin-ajax.php?action=wdf-ipn-return-paypal HTTP/1.0" 406 226 "-" "PayPal IPN ( https://www.paypal.com/ipn )"
173.0.81.1 - - [26/Oct/2014:17:59:14 -0400] "POST /wp-admin/admin-ajax.php?action=wdf-ipn-return-paypal HTTP/1.0" 406 226 "-" "PayPal IPN ( https://www.paypal.com/ipn )"
173.0.81.1 - -

  • Tyler Postle

    Hey Daniel,

    Hope you're doing well today and thanks for your question!

    It looks like the IPN is fine. I've tested this on my own installation and it is working fine for me. Would you mind installing the WPMU DEV Dashboard so You can grant support access to your site? Then we can take a closer look at the settings and I can compare it to my own working site.

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Have you already checked for plugin conflicts by disabling all other plugins?

    Look forward to hearing back on this Daniel!

    All the best,
    Tyler

  • daniel

    Sorry - when I go to the Support Access tab I see the "Grant Access" button. But when I put my mouse on it, I cannot click. There's a red circle/slash. Here is the System Info dump:

    Version 5.4.32
    max_execution_time 60
    open_basedir
    memory_limit 256M
    upload_max_filesize 2M
    post_max_size 8M
    display_errors 1
    log_errors 1
    track_errors
    session.auto_start 0
    session.cache_expire 180
    session.cache_limiter nocache
    session.cookie_domain
    session.cookie_httponly
    session.cookie_lifetime 0
    session.cookie_path /
    session.cookie_secure
    session.gc_divisor 100
    session.gc_maxlifetime 1440
    session.gc_probability 1
    session.referer_check
    session.save_handler files
    session.save_path /tmp
    session.serialize_handler php
    session.use_cookies 1
    session.use_only_cookies 1
    error_reporting 4983
    E_ERROR
    E_WARNING
    E_PARSE
    E_CORE_ERROR
    E_CORE_WARNING
    E_COMPILE_ERROR
    E_USER_ERROR
    E_USER_WARNING
    E_RECOVERABLE_ERROR
    E_ALL
    Extensions bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, enchant, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imagick, imap, intl, ionCube Loader, json, libxml, mbstring, mcrypt, mysql, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell, Reflection, session, SimpleXML, snmp, soap, sockets, SourceGuardian, SPL, sqlite3, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Guard Loader, zip, zlib
    MySQL
    Version 5.6.17
    Driver mysql
    key_buffer_size 256 MB
    max_allowed_packet 256 MB
    max_connections 500
    query_cache_limit 1 MB
    query_cache_size 512 MB
    query_cache_type ON
    WordPress
    Version 4.0
    ABSPATH /home/imifs/public_html/dough/
    WP_CONTENT_DIR /home/imifs/public_html/dough/wp-content
    WP_PLUGINS_DIR undefined
    SUNRISE undefined
    UPLOADBLOGSDIR undefined
    UPLOADS undefined
    SUBDOMAIN_INSTALL undefined
    DOMAIN_CURRENT_SITE undefined
    PATH_CURRENT_SITE undefined
    SITE_ID_CURRENT_SITE undefined
    BLOGID_CURRENT_SITE undefined
    COOKIE_DOMAIN
    COOKIEPATH /
    SITECOOKIEPATH /
    DISABLE_WP_CRON undefined
    ALTERNATE_WP_CRON undefined
    DISALLOW_FILE_MODS undefined
    WP_HTTP_BLOCK_EXTERNAL undefined
    WP_ACCESSIBLE_HOSTS undefined
    Web Server
    Software Apache
    Version Unknown
    Address 173.236.27.202
    Host rs24.websitehostserver.net
    Remote HTTP Requests
    WPMU DEV: GET OK
    WPMU DEV: POST OK
    PayPal API: POST OK

  • Tyler Postle

    Hey Daniel,

    Thanks for the quick response :slight_smile:

    All that information looks good. Since we can't do support access, would you mind sending in the login via our private contact form?

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    You can include the FTP in-case we need to take a closer look into the files. It will save us from having to ask for it later if needed!

    Look forward to hearing back.

    All the best,
    Tyler

    PS. I am stepping out for a little while but I will be back tonight. That is if another staff doesn't beat me back to your thread :slight_smile:

  • Tyler Postle

    Hey Daniel,

    Just posting in the thread here to let you know that I have flagged SLS(coding experts). So they can take a closer look at all the information we have gathered so far and hopefully figure out what the issue is :slight_smile:

    Very sorry for the long troubleshooting process here Daniel, I will see if we can get this one escalated.

    Talk to you soon! Hope you're enjoying your week.

    Cheers,
    Tyler

  • Jose

    Hi there @Daniel,

    Hope you are doing great today.

    As per the information that you sent in the emails it is definitively an issue on the hosting side.

    The 406 error is returned by apache before reaching the endpoint. So, our code is not running at all.

    I went through similar issues before, and unfortunately the hosting companies refuse to help most of the times.

    As an example, you can check this link (longest thread ever):

    https://premium.wpmudev.org/forums/topic/having-issues-with-the-fundraising-gatewaycode580029#post-749106

    In that case, the member had no option other than move to a dedicated/VPS plan. This is because mod_security can not be disabled for a specific account in a shared hosting plan. You can even see in the thread that the support service from the hosting company claims that it is already disabled, and then they say that it can not be disabled.

    I saw in your emails that your hosting company is willing to cooperate in this case. That's great :slight_smile:

    Are you running in a VPS or is it a shared plan? If it is a VPS or dedicated server, I can try to properly configure mod_security.

    Please advise.

    Cheers,
    Jose

  • daniel

    Hello Jose,

    First, let me thank you for your attention to this problem. I really hope we can get it resolved. Fundraising seems like a great plugin in all other ways.

    Second, my hosting in company is GreenGeeks.com. I don't have a VPS but it is a "reseller account" so I have a few more options than a regular shared account. I find them to be very cooperative. They looked at the problem, and believed it was because of mod_security so disabled it for my account. They also reset my FSCage (whatever that is!) I also added this to my .htaccess

    #ADDED BY DZ MAYBE ADDRESS THE IPN PROBLEM
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Thirdly, I enjoyed reading the long thread you sent that did have a happen ending involving the Paypal character set being misinterpreted. Is there any reason we are not investigating that now?

    Fourthly, one final thought is that I'm running the plugin on a SUBDOMAIN. Is it possible that the main domain does not have mod_security in the .httaccess turned off and that is intercepting the IPN?

    In gratitude,
    Daniel

  • Jose

    Hi there Daniel,

    Sorry for the delay on my response.

    I enjoyed reading the long thread you sent that did have a happen ending involving the Paypal character set being misinterpreted. Is there any reason we are not investigating that now?

    Is it sarcasm or you really enjoyed it? It is the longest thread ever. lol
    We are not investigating the character set because that would affect only the IPN verification, which ocurrs in a later stage. In that thread we had a combination of differrent issues, first it was the 406 error and then it was a failed verification.

    In this case, we first need to solve the 406 error. There is no much to do in our side at this stage. The IPN call from paypal is not reaching the site at all. It is rejected before that.

    As I said before, I could take a look at the server configuration if it were a VPS. Unfortunately, shared plans -even when they are reseller plans- do not allow to change this kind of settings.

    Can you ask to your hosting if there is any other module or firewall on their servers that might cause this error?

    Is there a chance to move to a VPS plan or a different hosting?

    Please advise.

    Cheers,
    Jose

  • daniel

    No, I wasn't being sarcastic at all. I enjoyed following the process that eventually led to a solution and I'm hoping for the same kind of resolution for myself.

    Unfortunately, switching to a VPS is not in my budget right now and I just finished migrating a dozen sites to GreenGeeks so I really do not wish to switch hosts to resolve this issue.

    "Can you ask to your hosting if there is any other module or firewall on their servers that might cause this error?"

    Rather than me asking them (and not really understanding their reply), I have already opened a Level 2 ticket (QRJ-675-71622) @jose - could you contact support@greengeeks.com directly?

    Another possibility is for wpmu to create a subdomain for me to set up this fundraising page on.

    In gratitude for your attention!

  • Jose

    For future reference, we finally sort the issue here.

    The IPN requests from PayPal were being rejected with an error code 406.
    Everything pointed to a mod_security filter being triggered, even when the hosting company (in this case GreenGeeks) tried to disable it. I believe they tried to disable it partially, and it doesn't seem possible in a shared hosting.

    The solution was to change the IPN endpoint to a new URL where GET parameters are not needed.
    It seems that the combination of GET and POST parameters plus the unrecognized User Agent (PayPal IPN ( https://www.paypal.com/ipn )) and the empty referer where filtered as an unsafe request by mod_security.

    I'll be working on the necessary changes to workaround this in the production version and post back here once it is deployed.

    Thanks again @daniel for your continuos cooperation :slight_smile:

    Cheers,
    Jose

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.