gallery theme error code

after install gallery theme and try to upload photo (slide) but some error code appear :
Warning: move_uploaded_file(/1-inter-14.png) [function.move-uploaded-file]: failed to open stream: Permission denied in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2571

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpAio2TL' to '/1-inter-14.png' in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2571

Warning: chmod() [function.chmod]: No such file or directory in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2572

Warning: getimagesize(/1-inter-14.png) [function.getimagesize]: failed to open stream: No such file or directory in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2126

Warning: getimagesize(/1-inter-14.png) [function.getimagesize]: failed to open stream: No such file or directory in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2120

Second issue when i try to upload logo : another error code show :
Warning: move_uploaded_file(/1.gif) [function.move-uploaded-file]: failed to open stream: Permission denied in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2239

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpwaDWQZ' to '/1.gif' in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2239

Warning: chmod() [function.chmod]: No such file or directory in /home/son/domains/propertyagent.my/public_html/wp-content/themes/gallery/library/functions/option-functions.php on line 2240

can guide me how to solve this problem ?

  • DavidM

    Heya SonnyCooL,

    Like Tim was saying, it does seem there's a permissions issue. I'm wondering if maybe a direct copy of the theme to the folder on your server via FTP would resolve that though. It's noted in the installation instructions as follows:
    https://premium.wpmudev.org/project/gallery-theme/installation/

    Also, you might want to check the permissions on your wp-content directory. Should be 755 I think.

    Could you let us know how either of these go?

    Thanks,
    David

  • SonnyCooL

    Are you running suPHP? or does your server 777?

    Different server environments have require different approaches.

    All the folders are present? Just making sure that creation of all required folders happened?

    What u means different server different environment ?

    Last i check on installation guide, it din't show anything abt server environment ... as long it able to install wp, should be ok ...
    It just a simple theme installation and it took me more then 24 hour for dedicated support to response (still no response yet) ......

    Hi can anyone show me right direction ? direction not telling me u can and i can't then i need to find solution by myself ........

    Theme Installation and Use Instructions

    Installing a theme from WPMU DEV

    1. Download the theme file
    2. Unzip the file into a folder on your hard drive
    3. Upload the folder to /wp-content/themes/ folder on your site

    * If you're using multi-site you'll need to visit Network Admin -> Themes and Activate it there.

    4. Make sure your install path is correct for example: /www/var/site/wp-content/themes/thethemename not /www/var/site/wp-content/themes/themes/thethemename

    5. You’ll see several files and folders depending on the theme package. Most themes contain a folder for the parent and child theme within the folder called themes.

    6. Launch FileZilla or your FTP client - read more about using FTP and FTP clients here.

    7. Enter your domain name, your username and password. NOTE: the same username and password that you use to log into your cPanel.

    8. Click Quickconnect

    9. Upload both the parent theme folder and child theme folder to wp-content/themes/

    * For example, with BuddyPress Daily theme you need to upload bp-daily and bp-daily-child to wp-content/themes/ (bp-daily folder is the parent theme folder)
    * With Gallery you need to upload gallery and gallery-child to wp-content/themes/ (gallery folder is the parent theme folder)
    * We provide child themes with themes to enable you to customize your own files without having those changes overwritten when we update a theme.
    * To find out more about parent and children themes please visit our guide to parent and child themes.

  • Timothy Bowers

    What u means different server different environment ?
    Last i check on installation guide, it din't show anything abt server environment ... as long it able to install wp, should be ok ..

    Well as I said different environment requires different things.

    I run suPHP on my servers and so all my folders must have 755 and all files should 644. Some setups are not as strict and allow folders to be 777 and not require an owner to run them (security issue as well). Windows servers sometimes require other things.

    These are your errors:

    - failed to open stream: Permission denied
    - Unable to move
    - No such file or directory

    Perhaps ask your hosting provider if they can shed some light on the mater.

    Hi can anyone show me right direction ? direction not telling me u can and i can't then i need to find solution by myself ........

    Ok I'll stop trying to help by making suggestions which could point you in the right direction!

    Good Luck!

  • SonnyCooL

    What u means different server different environment ?
    Last i check on installation guide, it din't show anything abt server environment ... as long it able to install wp, should be ok ..

    Well as I said different environment requires different things.

    I run suPHP on my servers and so all my folders must have 755 and all files should 644. Some setups are not as strict and allow folders to be 777 and not require an owner to run them (security issue as well). Windows servers sometimes require other things.

    These are your errors:

    - failed to open stream: Permission denied
    - Unable to move
    - No such file or directory

    Perhaps ask your hosting provider if they can shed some light on the mater.

    Hi can anyone show me right direction ? direction not telling me u can and i can't then i need to find solution by myself ........

    Ok I'll stop trying to help by making suggestions which could point you in the right direction!

    Good Luck!

    I ain't blind, i read thru every single step and try it, but it ain't work, no folder create even i set 777, nothing happen there.
    And how many hour should i wait for Technical support team to support on this issue ?

  • Mason

    Hiya SonnyCool,

    Our own Support rep responded to you above :slight_smile:

    I actually think Tim has a valid response to your issue here as well (Thanks again Tim!) especially as you're having very similar errors in regards to the image login plugin.

    I asked about directory permissions over on that thread as well. 755 is the default for WordPress installations and the fact that you're having multiple issues over the same thing would lead us to believe that somewhere, something isn't correct in this regard.

    We'll keep working with you here, but it's difficult to troubleshoot when we're not able to replicate the issue :slight_frown:

    So, let's double check your folder's permissions - and finally, try activating the default twentyten theme and uploading an image, does that work for you? If not - it's definitely an install/setup issue and not the plugins/themes here.

    Let us know!

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.