GCal Appointments 1 Hour Early During Daylight Saving Time

Hello,

Issue #1

I believe I have finally gotten the Appointments+ Plugin integrated with Google Calendar to the point where it is syncing back and forth almost perfectly. My major issue now is that all of my appointments after the start of Daylight Savings Time (March 9, 2014 2AM) are reading as one hour too early. I am hoping this is a simple fix with a code snippet of some sort that will tell the plugin to set the appointments one hour later.

Issue #2 - Totally Separate:

If I block something off from 3-4pm in Gcal, is it possible that I can also be unavailable for an appointment in the time base periods immediately before and after? So if my time base was 30, I would appear as actually busy from 2:30 to 4:30? I realize we can also solve this by changing the time of the appointment in GCal to 2:59-4:01 -- would it be possible to do that within the code of A+ to where it blocks off one minute before and after?

Thank you.

  • PC

    Hello there Parker,

    Thanks for posting on the forums.

    I believe I have finally gotten the Appointments+ Plugin integrated with Google Calendar to the point where it is syncing back and forth almost perfectly. My major issue now is that all of my appointments after the start of Daylight Savings Time (March 9, 2014 2AM) are reading as one hour too early. I am hoping this is a simple fix with a code snippet of some sort that will tell the plugin to set the appointments one hour later.

    I see that you are using WordPress 3.5.1 due to which this might be happening. Can you kindly upgrade to the latest version to ensure compatibility and try again ?

    If I block something off from 3-4pm in Gcal, is it possible that I can also be unavailable for an appointment in the time base periods immediately before and after? So if my time base was 30, I would appear as actually busy from 2:30 to 4:30? I realize we can also solve this by changing the time of the appointment in GCal to 2:59-4:01 -- would it be possible to do that within the code of A+ to where it blocks off one minute before and after?

    Not that I am aware of I am afraid. The reason is that the time shown busy in Gcal is shown as reserved by gcal and hence busy on the calendar so that we can avoid booking.

    The easiest way to do it is show yourself busy on the calendar itself and hence book that slot.

    Let me however check with @Vladislav to see if we can have an addon for this purpose. It can actually be pretty handy when we can choose the minutes before and after each appointment of busy slot and avoid bookings. Especially helpful for those who are using gcal for some separate work and need some time to get back to Appointments.

    Let me see what he thinks about it.

    Cheers, PC

  • parker_mason

    PC,

    Thank you for your quick response. Sorry that it took me a few days to update the Wordpress install.

    Issue #1 (Daylight Savings Appointments 1 hour early)

    Unfortunately, I updated to WP 3.8.1 and then did "Import and Update Events Now" and still there were 0 Appointment Records Affected. Just to make sure, I then went and added a new event on March 18 at 2pm and then Imported events again. It shows up as March 18 1pm. Any ideas how to get these to shift to where they are supposed to be? This is particularly frustrating because otherwise the plugin is working exactly as it should, and seems to be integrating seamlessly with Gcal.

    Issue #2 (Blocking off additional time for appointments)

    In regards to the addon you mentioned, that would be a HUGE help for me. Many calendar events on my calendar are off-site and booked with another person on the calendar, so I cannot simply change every 3pm-4pm appointment to 2:59-4:01pm without affecting everyone else's calendar. So unfortunately we are stuck creating dummy appointments or manually blocking off time.

    I'd love to be able to specify that just on the "Make An Appointment" page, the time base period before/after each appointment could be shown as unavailable without having to go and actually change any events in the calendar.

    Thanks for your help!

  • pxwm

    Hi @parker_mason

    I've checked the settings and they look fine.
    I have known certain plugins cause a time conflict.
    If you have any other plugins activated is it possible you can deactivate them all then try making an appointment.

    Just out of interest do you have the BackWpUp plugin activated?
    If so you may wish to try deactivating this first.

    As always I would suggest you take a full backup of your site and database before deactivating any plugins.

    Regards
    SteveB

  • pxwm

    Hi @parker_mason

    I'm not sure any of these plugins would cause the problem you have so is it possible you could provide a screenshot of your A+ GCAL tab.

    I would also appreciate if you could check the following:-

    Could you create an appointment through A+ front end noting the time slot then check in A+ admin if the appointment is in the 'Active appointment' tab and if so has it saved the appointment with the correct time.

    After 15 mins could you also confirm it has sync'd to your GCAL and if so what time is has booked?

    Regards
    SteveB

  • parker_mason

    @pxwm,

    I am sorry it took me so long to follow up on this. Sometimes you just have to work on other projects!

    So, I created two appointments through the A+ admin. I created one for March 6 (pre-Daylight Savings) that shows up exactly as it should on the GCal. I then created one for March 19, that, as expected, shows up one hour too late on GCal. Just to clarify - I created an appointment in A+ for March 19 at 2pm, and on GCal it is showing that the appointment is at 3pm.

    Any ideas for anything I can try? Thanks so much for your help.

  • pxwm

    Hi @PC Any chance you could request @Vladislav have a look

    Hi @parker_mason

    I've had a further thought on this and I can recall we had the same problem and if I recall correctly this is what will happen:-

    If you made an appointment today (before daylight savings) through the A+ front end for an appointment in the future, lets say Mar 31 @ 11:00 (after daylight savings) and this would show up in your google calendar for Mar 31 @ 12:00

    However I'm pretty sure that when daylight savings kicks in for your region then your google calendar would change the appointment to 11:00 and it would stay as 11:00 in A+.

    I'm also not sure what would happen if you made the same appointment but through the google calendar and approved whether this time would change on the daylight saving day.

    I'm also not sure what would happen if an appointment was made between midnight and 01:00 in the morning of the daylight change.

    Regards
    SteveB

  • parker_mason

    @pxwm

    I believe you are correct. I tried one more thing to make sure.

    I changed my Google Calendar time zone to Lima, which is in the same time zone (GMT -5) but does not observe Daylight Savings. All of my events after Daylight Savings shifted back one hour -- exactly as they are showing up in A+. So yes, it would appear that Google took into account DST when the events were created, and A+ is not taking that into account. I have changed the calendar settings back to where they were and now the events are showing up correctly again in Google Calendar, but still incorrect in A+.

  • parker_mason

    @pxwm @Jack Kitterhing @Vladislav,

    For what it's worth, the GCal appointment time is now working correctly during Daylight Savings Time. The appointments changed over to the correct time as soon as DST began. However, I anticipate that this will again become a problem when we approach every time shift. Hopefully it's an easy issue to fix in an update. Thank you for your help.

    Also, @Vladislav, still very interested in the above "Issue #2" that I posted in the original post of this thread. Would be great if this was possible.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.