GCal do not update Appointments +

Hi, thanks for a wonderful plugin :slight_smile:
Unfortunately I can not get a service provider´s own GCal to block hours in Appointments + calendar. Booked appointments on the website show in service provider`s GCal so it is a connection between them. API mode is sett to: A+ <-> GCal , so it should be working.

Any clue what could be wrong?

Thanks,
GeO

  • Denitsa

    Hello Geir-Ove,
    I hope you're doing good and thanks for reaching us!

    This sounds as an already reported issue with the plugin. We have a fix ready that will be included in the next release - I have attached the fixed file here.

    So until the fix is out with the official plugin update, can you try replacing the /wp-content/plugins/appointments/includes/class-app-gcal.php file via FTP with the one from the .zip archive I've attached here?

    I apologise for the inconvenience and thank you for your patience!

    Regards,
    Denitsa

  • Sajid

    Hello Geir-Ove,
    Hope you are doing good today :slight_smile:

    I can see in our private discussion channel. Denitsa tested it on her own site before providing it to you and it worked for her.

    If it does not work right then, either means you have not applied the patch correctly or the issue is different.

    Please note that, the patch is for fixing the issue of not importing events from Gcal to Facebook automatically.

    If that is the issue you are facing, then please send in FTP and WordPress admin details privately via our contact form and we will do it for you.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    After applying the patch, in case it still don't work on your environment, we will be troubleshooting this issue. During the troubleshooting, we will be temporarily deactivating plugins/themes and may connect our own Gcal account with A+. Of-course we will revert it back afterwards.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello Geir-Ove,
    Hope you are doing good today :slight_smile:

    Thanks for sending in the FTP and WordPress admin details. I have applied the patch. Please check again and let me know if you need help.

    Also, please specify that you are getting issue with importing events from google calendar to A+ ?

    Or it does import events but does not block the time slot ?

    If it does import events and does not block time slot for that provider. Then make sure the timezone of your google calendar matches with the one you selected in WP Dashboard -> Settings -> General.

    Best Regards,
    Sajid - WPMU DEV Support

  • Geir-Ove

    Hello Sajid,

    thank you for your time! :slight_smile:

    I have tested it several times now, reset API and connected GCals again, but GCal still don´t update A+ automatically. It will only import events from GCal if I manually press button "Import and Update Events from GCal" from Admin login i WP. But then I have to be connected to Service Providers GCal and select his Calendar from settings. If I connect another calendar from settings (reset API - and connect new calendar) the previous imported events is deleted. It is some sort of communication between GCal and A+, but think something is stil wrong.

    Best regards,
    Geir-Ove

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.