Getting 404 errors - permalink issues?

I am getting 404 errors on my blog posts. My 404 page shows the permalink, but something is very wrong :slight_frown:
http://hamptonchurch.co.uk/test-2/

  • aecnu
    • WP Unicorn

    Greetings PoshWeb,

    Thank you for bringing this item to our attention.

    Have you reset the permalinks? You do not need to change your current permalink setting, just click on save which will indeed reset them.

    Does the page test-2 exist? Screen shot of your pages listing please.

    And what do the rewrite rules in your htaccess file look like? Screen shot please?

    Please advise.

    Cheers, Joe

  • PoshWeb
    • Design Lord, Child of Thor

    Don't worry i've fixed it!

    I disabled the "permalinks" option on my branding plugin, saved the permalinks then re-enabled the option in the plugin and it started working.

    While it's great that it now works, i can't help but be a little worried. My plan was to have the permalinks menu option hidden on all user blogs, and have it set up as /%postname%/ as default - maybe that's not possible if it is going to cause errors?

  • aecnu
    • WP Unicorn

    Greetings PoshWeb,

    Thank you for the update and we are indeed making progress.

    Sure you can hide the permalinks from the end users without causing issues like this though I am not sure what you are using to hide it form them and you can set the default to /%postname%/

    What branding plugin are you referring to?

    Ultimate Branding?

    Please advise.

    Cheers, Joe

  • PoshWeb
    • Design Lord, Child of Thor

    Hi Joe,

    Here is my config > parent site is hosted at wpengine and has pro-sites, ultimate branding and domain mapping installed.

    Here is my scenario > I add a new site to the network and map the domain.
    When i go to sites and click the "settings" tab i can see that my default permalinks are set to:
    /%year%/%monthnum%/%day%/%postname%/

    I change this to /%postname%/ and hit save changes.

    When i create a post, my slug is correct ie: "test-post" but when i navigate to website.com/test-post/ i get a 404 error.

    If i then disable ultimate branding, go to my site's dashboard and save permalinks there - it fixes the issue. (i can now re-enable ultimate branding without issues)

    What i would like is to be able to set up defaults so that every time i add a new site to the network, it has /%postname%/ automatically. It would also be nice if i could choose a base theme and have it populated with some content.

    Thanks for your time,
    Regards
    John.

  • aecnu
    • WP Unicorn

    Greetings John,

    Thank you for the additional clarification which is certainly appreciated.

    Considering your last post and what you have mentioned there, if I understand what you have in mind, I believe what you are indeed looking for then is the New Blog Defaults plugin which should indeed takes care of the items we have discussed.

    Please advise if in fact this has done the job for us.

    Cheers, Joe

  • Tom Eagles
    • Syntax Hero

    Hiya, just going through some of the older threads here.

    As it's been a little while since we last heard from you I thought I'd check in to see how you're going?

    If you're still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.

    Cheers!
    Tom

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.