Getting allways the messages: Anti-Splog is not fully

Getting allways the messages:

Anti-Splog is not fully enabled. You must enter your WPMU DEV Premium API key to enable the powerful blog and signup checking. More info» Dismiss

If I try to fill in the API Key i get:

There was a problem connecting to the API server. Please try again later.

My Multisite is listed in my settings.

Any idea?