Getting an empty response error when I try to make a backup

I'm not able to run Snapshot backups, for Managed Backup, it is giving empty response error, for Snapshots
405 NOT ALLOWED
nginx/1.14.0

Can you help me, please?

  • Kasia Swiderska

    Hello Manelle,

    I checked your site and I was able to run Managed Backup till it finished without any errors.

    It took a while but it was completed.

    I do however see that Snapshots are stuck at plugins directory when taking a whole Snapshot. But when I divided Snapshot to two parts: one for only plugins and second for the rest it worked. So now there are two completed Snapshots:

    This makes me think that problem is with resources, however, I'm not able to check it because access to hosting panel you have provided during the chat was not working. So I can't enable debugging.
    Can you send those again via our safe contact form?

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Kasia Swiderska"
    - Site login URL
    - Hosting credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

  • viobru

    Hi, Manelle!

    Hope you are doing great and thanks for sending the creds :slight_smile:

    I was checking this and I noticed that for some reason the front-end was not properly displayed, it was showing:
    This usually happens when there is no idex.php file on the site, so I added the default index.php to the root folder of the site and now the front-end is properly working.
    I also noticed that there was a info.php file on the root folder of the site which is usually used to check the PHP info while troubleshooting, but should not be left there since it makes this sensitive information publicly accessible, so I've removed the file from the server.

    Apart from that, seems that WP_DEBUG was already enabled on wp-config so I tried running a new snapshot to check if there was any error logged after doing so. The complete snapshot got stuck while processing the plugins folder and on debug.log the only warning that was logged was the following one (this is the only one that is logged and there are already over a thousand logs of it):
    [01-Nov-2018 19:55:13 UTC] PHP Warning: fileperms(): stat failed for /home2/manelleo/public_html/t*******tic.com/index.php in /home2/manelleo/public_html/t******tic.com/wp-admin/includes/file.php on line 1423

    I also checked that there were a couple of errors logged in the console when running the snapshot:
    I searched the server error_log to check this internal server error, but I can find the error logs on the server (I guess that they are hidden). Please, check with your host if they can provide the server error_log to check the details of this internal server error and please share the error_log details with us on this thread.

    Looking forward to hear from you.

    Kind regards,
    Violeta

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.