Getting an error after updating

I just updated my plugins including Domain Mapping. I updated from 4.2.0.6 to 4.3.0.1. I still have a message indicating I need to update from 4.2.0.6 to 4.3.0.1. There is no box beside it to select update again. My "changelog.text" file in the plugin folder indicates I'm still running 4.2.0.6. Can you advise?

Thanks,
Larry