Getting an Error on Plugin Install

I'm receiving the following error when I try and install plugins (I tried with several) on only one of my sites, using the WPMU DEV Dashboard plugin. All of my other sites were able to install a new plugin without a problem.

One thing I noticed is that, when I added WPMU DEV Dashboard to this new site, it took quite a while to install. Far longer than usual. I don't know if this caused a problem or not, but it's obviously not working.

Here's the error I get when trying to install the Events+ plugin:

Downloading install package from https://premium.wpmudev.org/wdp-un.php?action=install&key=(MyAPIKey)&pid=249…

Unpacking the package…

Could not copy file. events-and-bookings/lib/class_eab_event_model.php

I'm not sure where it's trying to copy the file from. It's obviously looking like a permissions issue and all of the permissions I know to check look good. Maybe I'm missing something?

Thoughts?

Thanks,

Ben