Getting DNS Issue on the new subdomain blog

Hello -

First and foremost, I'm grateful for all the help I received so far. this is a great forum. I've installed the new blog templates piece on a site and I can register to get a blog as a subdomain BUT when I click on the link it throws a DNS entry.

Is there something I didn't write in the htaccess? In the config file?
http://test.engmgtlabs.com/wp-activate.php?key=f90bfb11a665bdf3

I ran through the forum and searched:
- dns_unresolved_hostname
- DNS issue installing new blog template
- DNS issue blog template
- DNS issue template

I didn't find anyone with this issue. I'm sure it's going to be something really really dumb.

Philip

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Well I think we should go over the specifics and see if we can figure out what is going on here.

    We should first start with:

    WordPress 3.3.1?
    Obviously MultiSite?
    Buddy Press?

    *.maindomainname.com DNS entry?

    Shared Hosting or Dedicated?

    Shared IP or Dedicated?

    Please advise.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    Hello Aecnu -

    Thank you very much for such an incredibly fast response!

    Wordpress 3.3.1
    MU site installed
    No buddy press
    Magazine basic theme

    test.engmgtlabs.com dns entry (is that what you wanted)
    shared hosting
    dedicated IP
    - how can i confirm those last two?

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Now that I have the URL I am able to do a significant amount of digging.

    Your DNS issue and why test.engmgtlabs.com is not working is because there is no *.engmgtlabs.com A record as indicated below by my screen shots of your DNS records on your server.

    Therefore you need to create a DNS record, an A record, that is *.engmgtlabs.com

    This usually can be done in your hosting control panel in the dns for this domain choosing create an A record and then when the box comes up just put in * and save.

    Then depending on the hosting it will either work right away or you may need to restart the DNS server if you indeed have the capability.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Just to let you know that as of 4:40 US Eastern Standard Time the record does not appear in your DNS as if it was never entered.

    This does not require propagation time since I am running a real time DNS query.

    Please advise your host to the this problem at your earliest convenience to see what they have to say about it.

    Then let me know.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Tell them I said thank you for the cool new tool and that I have confirmed the setting, the tool I was using when I tested again it says that it is using a cached version of the DNS - this is probably why it was not showing up.

    It is 100% certain that it is shared hosting - with approx 870 other sites as indicated below with the reverse IP lookup.

    Next ask them if they would be so kind as to tell us if you have a dedicated IP - why does a reverse IP lookup show that there are 870 domains hosted on IP address 174.127.110.27

    http://www.domaintools.com/research/reverse-ip/?hostname=engmgtlabs.com

    The above is not cached and it is a different tool we use.

    This is not so critical as if using Domain Mapping, but if your paying for a dedicated IP then .... if not paying for a dedicated IP then do not mention it to them, unless you intend to do Domain Mapping it is not such a big deal. If you are going to do Domain Mapping then it is most likely critical.

    Now when running a test of your domain http://test.engmgtlabs.com/ I am getting a different page then before that now says:
    Template Error: The template file must be given

    Have you setup the New Blog Template plugin?

    Please advise.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    Joe - Many thanks for such an amazingly fast response. I appreciate it - as well as your description of what I should say to the company. I'll ask. It's cheap dirty hosting.

    I've followed the directions and even tried to do one from normal.

    I'm getting that file issue, too.

    1. Settings > Blog Templates
    2. Filled in:
    > template name
    > ID 1 That's the site
    > description and title "template"

    On "What do you want to copy..." I checked the following boxes:
    - Wordpress Settings, Current Theme, and Active Plugins
    - Files

    (I also tried a few combinations including all or nothing.)

    Also tried to 'create a new blog'

    Sites
    - gave a subdomain name
    - created it
    - I can click into the dashboard and get a 404 (check6.engmgtlabs.com/wp-admin/ (port 80))

    - click the "edit site" I can get into the dashboard but when I click on the URL above I get the template issue.

  • aecnu
    • WP Unicorn

    Greetings Philip,

    By any chance did you make the main site the template site?

    This would be a mistake that can be easily corrected if you did so do not panic.

    If you did I recommend making a sub domain something like template.yourdomain.com the template site.

    This will prevent a lot of pain in the future.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Well we are getting closer :slight_smile:

    I believe you are referring to how you make a new site from the template when I am in fact talking about which site is the template itself.

    As it says in step 2 below:

    2. In the WordPress dashboard go to Network Admin > Sites and hover your mouse over the site you wish to use as the template. In doing so, the site id (which will be used as the Blog ID) will show in the link in your browser.

    For best results this should be a sub site and not the main site. Is this in fact what we have, the template site is a sub site and not from the main site?

    The reason why I am homing in on this is that previous folks have cured many a problem when the template is a sub site and the sub sites are created from this very sub site template.

    Hopefully that last statement did not send your head spinning.

    Please advise.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    That is for certain.

    The id of the site is 1 the actual information from the rollover is: engmgtlabs.com/wp-admin/network/site-info.php?id=1

    That is the one that i used to create my template.

    When I first installed it and began to get errors, I checked through the steps. They're clear (the screenshots are old) but it's certain what they're doing.

    I do understand that the MU folder doesn't need to be there. It's odd that I can't find other people with the same problem? What am I overlooking?

    Sorry for the back and forth. I appreciate your help.

  • phifraphofum
    • Design Lord, Child of Thor

    That is for certain.

    The id of the site is 1 the actual information from the rollover is: engmgtlabs.com/wp-admin/network/site-info.php?id=1

    That is the one that i used to create my template.

    When I first installed it and began to get errors, I checked through the steps. They're clear (the screenshots are old) but it's certain what they're doing.

    I do understand that the MU folder doesn't need to be there. It's odd that I can't find other people with the same problem? What am I overlooking?

    Sorry for the back and forth. I appreciate your help.

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Thank you for the additional information and I think I have spotted where the problem is which is in fact that site ID 1 or the main site was used for making the template.

    All those that I recall whom have done this in the past have had nothing but trouble with it.

    One of the reasons is because site ID 1 is not like the rest of the sites nor is it in fact a sub site. Its data nor images are kept in the blogs.dir folder like the rest and other major differences.

    Therefore it is my opinion that this needs to be changed to a sub site for you to get the results you expect without error i.e. site id 2 or higher.

    So in essence, we need to make the main site or site id 1 back the way it was originally or more accurately without it being the template site and indeed make a sub site the template site so this will work for you without error.

    Please advise.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    There's hope.

    I changed deleted the template.
    Made a new site in Network Admin
    Created a new site
    Used the new id "7" to make the template
    Made it default
    ...I've registered three times with three different emails and I'm not getting any emails or showing that the new sites are pending.

    Looking into it. Will follow up.

  • aecnu
    • WP Unicorn

    Greetings Philip,

    It's still not working. This shouldn't be that difficult.

    You are absolutely correct that it should not be this difficult.

    After looking over our entire ticket here I realize that due to the infinite possibilities of hosting configurations and the fact that your DNS is resolving, from an older wordpress codex I remember that one must set the httpd.conf or vhost.conf for the domain in question with a server alias *.domainname.com

    Therefore with this in mind, at this point I would ask your host to add to the httpd.conf file or vhost.conf file for your domain the following line as a server alias for your engmgtlabs.com domain:
    *.engmgtlabs.com

    Your server alias line for your engmgtlabs.com domain should then appear something like:

    ServerAlias engmgtlabs.com http://www.engmgtlabs.com *.engmgtlabs.com

    NOTE: not http:// in front of the domain name above - the darn ticket system is adding this to my code!

    Of course after the change they will need to restart apache for the change to take effect but they should surely be aware of this.

    That should do it.

    Please advise.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    Hello Joe -

    I thought I had done this, but to make sure I sent an email to the support team of my site. I included this thread as well. Here's their response:

    Thank you for contacting Technical Support.
    I am sorry for the delay in our response.
    I believe that what they are suggesting is a subdomain wilcard.
    Currently the * Alias is already there, for the the domain engmgtlabs.com, as described in the ticket.

    It does not seem like the issue would be caused by this, but something else.

    I won't give up if you don't.....

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Surrender is not an option!

    Hmmmm - but there is no way to externally check them as we can with DNS.

    Since it is my job to resolve issues for members regardless of the source of the fix (as long as it is legal of course), I suggest we try a different approach using a different Domain Mapping plugin --> WordPress MU Domain Mapping plugin

    You will want to deactivate Domain Mapping plugin and activate WordPress MU Domain Mapping plugin

    One other thing though, we have confirmed above that they have over 800 domains on your so called dedicated IP, have they offered an answer how this is possible?

    This could be the very reason we are having so much trouble with this.

    Please advise.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    OK So I checked and it's a shared IP.

    So this won't work with a shared IP? I'm reluctant to think this is not going to work. It's too good of a model for a few of my clients.

    So let's do this. Let's confirm the very basics of the set up of the site - down to whether or not Multisite is up and active for the site. I thought it was - but I seriously refuse to think it would be this difficult to do anything in with Wordpress.

    OK. So throw me the very basics:
    - what would you need for confirmation of the very basics and let's go from there.
    - could these plugins be installed the wrong way
    - is there a need for me to share my login of this site? I literally created this site to prototype ideas - so I'm happy to work with you however close you need.

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Well it is my opinion that the main problem we are having now is from not having a dedicated IP.

    There was one point in this ticket that you indicated that you had one:
    https://premium.wpmudev.org/forums/topic/getting-dns-issue-on-the-new-subdomain-blog#post-201589

    and in another I pointed out that it was not so:
    It is 100% certain that it is shared hosting - with approx 870 other sites as indicated below with the reverse IP lookup.

    Next ask them if they would be so kind as to tell us if you have a dedicated IP - why does a reverse IP lookup show that there are 870 domains hosted on IP address 174.127.110.27

    http://www.domaintools.com/research/reverse-ip/?hostname=engmgtlabs.com

    Therefore our most certain problem since this has not been resolved is a dedicated IP.

    Domain Mapping must have a dedicated IP (unless the host is really good with httpd.conf and vhost.conf customizations)

    From the very first paragraph of Domain Mapping instructions:
    First of all we need to check... You are running your WordPress website as a multisite right?
    Because if not then you won't be able to install this plugin.

    For using A Record setups, you also need to ensure you have a dedicated IP. This IP would fall onto your multisite setup. i.e. when you enter the IP you see your multisite.

    This is about as basic as it gets :slight_smile: since we are starting with the IP.

    Please advise about us getting a Dedicated IP for this project.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    OK. Incredible news. It works. It's working. I don't get the 404 issue! I can almost touch it!

    When I generate a new site though, it goes to my original site.

    So - the test site is engmgtlabs.com
    I create a site that has the subdomain there.
    - then I get the email. And the subdomain refers back to my OTHER site engmgt.com. I've tried a few times to create a template - but it seems to refer back to my other site and not engmgtlabs.com

    I hate to ask this BUT this is because the static domain is for engmgt.com and not for the engmgtlabs.com - correct? I was told that the static domain would be applied to all sites that I'm hosting - do they mean that any site I'm hosting - in this circumstance - would need to refer back to another site?

    Does that make sense?

    Again. Thank you for hanging on for so long.

  • aecnu
    • WP Unicorn

    Greetings Philip,

    Not a problem, just trying to help anyway that I possibly can :slight_smile:

    I am happy to hear that you have had some victories in this.

    From what I can tell they still have you on a shared IP, and that your WordPress domain is still not on a dedicated IP just for the WordPress MultiSite installation, which is certainly the ideal situation.

    Today a reverse IP check indicates that your domains IP now has 861 web sites on it down from 870 the other day.

    I do not know why or how the top level domain engmgtlabs.com would revert back to the engmgt.com if this were all setup correctly on the hosts side.

    Even if engmgtlabs.com is an add on domain, how it reverts back to engmgt.com is an unknown only the host can answer at this point with them being able to see the server configuration.

    As my main job of being Global Network Administrator for two other corporations aside from working with WPMU Dev, it is my opinion that something is rotten in Denmark so to speak concerning this hosting configuration, dedicated IP, etc. and until the configuration is addressed and provided to facilitate the WordPress MultiSite configuration that anomalies will persist.

    Please advise as to what we have to work out next even considering this configuration.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings phifraphofum,

    Please advise as to what other domains on on this hosting account?

    In the following post which is above you mentioned that this is a shared IP:
    https://premium.wpmudev.org/forums/topic/getting-dns-issue-on-the-new-subdomain-blog#post-205452

    No it does not work on shared IP's.

    Who said it was a shared IP?

    I believe your hosting company said it was a shared IP?

    Then how can they turn around and say it is a dedicated IP?

    Though surrender is not an option, there is a limit to what I can do with this and we (meaning you and I) are getting the run around.

    Please advise as to what we are dealing with so I truly know if this is a lost cause for us due to the obviously not straight answers we are getting from your host, is it or is it no a shared IP is the question.

    Cheers, Joe

  • phifraphofum
    • Design Lord, Child of Thor

    Ok. It was a shared IP.

    I bought a service that made it a dedicated IP.

    I have three other urls under my account.

    If you are saying that it works only if:
    1) it is the only domain assigned to a dedicated IP (which is different than it being NOT a shared IP)
    2) it uses a PTR record to generate the template that makes the sub domain

    Let's not take the tangent of going back in history; I'm buying new services to accommodate this plug in. I am a newbie and non-techie; it is one of the reasons why I'm using Wordpress in the first place.

    Please confirm the above two points. If that is the case, then I'll take the additional steps to makes sure it is the only single URL on the dedicated IP. I was doing things to economize but for these things to work I'm happy to do whatever needs to be done.

  • phifraphofum
    • Design Lord, Child of Thor

    OK. Now I'm seriously confused and getting frustrated.

    1) During this conversation I BOUGHT and CONFIRMED that the IP was dedicated
    - I supplied the links that proved it
    - I am hosting five other URLs under the account (two are redirected)

    2) Joe, at this point, I can only say that you seem to be trying to find a way out of this by blaming it on the host provider - and then PC comes along and says it doesn't matter.

    What is going on? Seriously? If there is a WE in this (meaning you and I) don't point fingers at a hosting company only to be disproven as to what the issue could be in the first place.

    This is getting frustrating! Is it the PTR file? Is it something else?

    I've
    - purchased an additional URL
    - purchased additional services from my hosting provider

    What really needs to happen? Tell me what i can do to resolve this? Is there a debugger I can load? Is there some plugin that will reveal some structure or error in my files?

  • phifraphofum
    • Design Lord, Child of Thor

    I just reconfirmed that the URL was dedicated. this is truly getting ridiculous. What the hell is it that I'm overlooking at this point.....

    Wild card is in.
    Dedicated IP (even though obviously it doesn't need to be)
    Template is set up
    ID is 8
    registration process is working
    up to the point of confirming the URL then it reverts to another website

    what the heck!!

  • phifraphofum
    • Design Lord, Child of Thor

    Nope that didn't do it.

    Back to square two. Here's the problem as it is:
    - the template in site manager has an ID of 2
    - in creating the template - it creates a copy of ANOTHER site under my dedicated IP
    --- so I go through the registration process for B.com and it gives me a template for A.com
    - In the email that I get it has a registration is closed erro
    - the template that is created is the another site

    I feel that PC showed that it has nothing to do with whether or not it's a shared site

    I went through the thread and didn't find anything.

    I'm lost. Seriously. I was so close. I haven't heard anything. This is extremely frustrating. I'm sure - for everyone.

    What the heck can I do to complete this?

    Philip

  • phifraphofum
    • Design Lord, Child of Thor

    Hello Joe -

    On April 4, you asked me to add a server alias to the site. Is that the same as the wild card? I'm truly hoping I can address this. This solution will assist in an online fundraising alternative for schools in my area and I simply cannot let this go.

    ThAnk you for your help. If you don't respond I'll open a new thread off this new problem.

  • PC
    • WPMU DEV Initiate

    @Arun : I checked all the settings for phil's setup, found that the issue somewhere is with the DNS settings which seems to be messing up with the activation request handling.

    Example :

    To activate your blog, please click the following link:

    http://pranayachaudhary.engmgtlabs.com/wp-activate.php?key=0000000000000

    Takes us to http://engmgt.com/wp-login.php?registration=disabled

    If you see, the domains in request are two different ones.

    @Phil : Have you got any settings up in the domain mapping (if you are using that) which might be sending the requests from labs site to the other site ?

    Do you have any views on this one ?

    Cheers
    PC

  • PC
    • WPMU DEV Initiate

    Also, I have checked and matched the DNS settings for Phil with those of my own websites, and they seem to be setup in a correct way here.

    Any idea, why the activation e-mail takes us to the main domain on the hosting ? i,e. abc.engmgtlabs.com/activate takes to engmgt.com and as registrations are disabled on engmgt.com, it gives the prompt...

    I should just not go to engmgt.com

    Cheers
    PC

  • PC
    • WPMU DEV Initiate

    Template at all was not a problem for this issue, subdomain which was being created automatically seemed to be creating issues.

    I am in discussion with the host for the same and will post the exact resolution soon.

    Cheers
    PC

  • PC
    • WPMU DEV Initiate

    And finally, I am going to mark this Topic as resolved.

    After 8 sleepless nights, I am here with a solution to the DNS issue on subdomain blog for phifraphofum

    Firstly, I would like to tell you what all I did to get to the root of the problem,

    I reinstalled WPMU on his domain engmgtlabs.com and still the problem was there.
    I checked the wildcard DNS entry which as per the guidance was looking fine, but that did not help either
    I removed the domain, re-added it and reinstalled the whole wpmu setup and it did not work

    Finally, to ensure that DNS is the problem child, I moved his domain to my hosting and reinstalled wpmu (Swear to GOD, I can not install wpmu with closed eyes :wink: ) and wow, it was working fine just like my other sites.

    Then, Finally I decided to hit the DNS editor of the hosting panel for phifraphofum and added the domain back, and instead of adding the wild card DNS to the DNS records, I thought of a work around.

    The basic concept of adding a wildcard DNS to your domain, is just to ensure that all the requests from anything.yourdomain.com to the right place... in WPMU context, it takes you either to the main domain (Provided if the registrations are disabled then you must have set the NOBLOGDIRECT correctly) or to the actual subsite (If it exists) or to the registration page which will offer you to register that subsite)

    So, instead of doing that using the DNS editor, I used the below 3 step approach

    Went to cPanel >> Subdomains.
    Add a subdomain called *.engmgtlabs.com
    Changed the document root to the document root of engmgtlabs.com

    And guess what, we are ready to go on engmgtlabs.com ! Wanna test, please go to http://anything.engmgtlabs.com (Which actually does not exist till now) and see the difference. No DNS error, nothing, just a cool registration page (On default theme though :smiley: )

    This came into my mind when I carefully noticed that previously all the requests from subsite.engmgtlabs.com/wp-activate were going to themaindomainonhostingaccount.com/wp-activate

    And, I am sure, that Dedicated IP or Shared Hosting, does not really make a difference in WPMU for Subsites.

    I hope that all the work done on this thread would help Philip create a great site as now the problem is fixed.

    Cheers
    PC

    Just about to reach that milestone Just need a few more gifts :wink:

  • PC
    • WPMU DEV Initiate

    to simplify

    Went to cPanel >> Subdomains.
    Add a subdomain called *.engmgtlabs.com
    Changed the document root to the document root of engmgtlabs.com

    Add a subdomain called *.engmgtlabs.com
    Set the document root of new subdomain to the one of the main domain

    Example, if home directory of engmgtlabs.com is /home then for *.engmgtlabs.com would also be /home

    Cheers
    PC

  • PC
    • WPMU DEV Initiate

    @Joe @Staff :-

    I have resolved this issue and also shared my solution in the above post.

    I am trying to mark this as resolved and due to some strange reasons, I am unable to do that. The box to mark it as resolved is grayed out :slight_frown:

    I would request @Joe or someone from the support team to review this thread, solution offered and close this thread as resolved :slight_smile:

    (Well I have to admit, it has been one of the longest threads, I have ever worked on :smiley:)

    Cheers
    PC

  • PC
    • WPMU DEV Initiate

    Heya @phifraphofum,

    Marking this thread as resolved. I found that IE was the culprit that I was not able to mark it as resolved before.

    Please feel free to post if you face any further issues at any point ! We are always around :slight_smile:

    Cheers
    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.