Getting Empty Response

Have issues with creating Managed Backup, and also with Snapshots to Dropbox.

Getting the following errors as below:

Please check the chat notes for more info.

  • Majid

    Hello Fernando
    We forwarded this ticket to our Second Level Support team to get their valuable feedback on this issue. One of our SLS members will reply back here as soon as more information is available.

    Please keep in mind that our SLS Team deals with more complicated issues, thus it may take a little longer for them to reply here. Thank you for your patience while we look into this further.

    Cheers,
    Majid

  • Lindeni Mahlalela

    Hello Fernando

    I hope you are doing great today. I am sorry that this was not working for you yet but I hope we can work together to resolve it.

    I have checked your setup and have seen the error reported on the thread. When running a Managed Backup in Snapshot it runs a compatibility check and displays any warnings on the screen before you can run the backup, according to this test there was one issue, the 'max_execution_time' was set to 30 seconds which is less than the recommended 150 seconds for Snapshot to be able to run properly.

    I have tried to use your cPanel to adjust this by going to "Software > PHP Selector" then open then click the "Edit Custom php.ini" button. I have set the max_execution_time to 700 and after that I changed the memory_limit to 512M. I have saved this but unfortunately it was not effective and I didn't find where cPanel saves this file, usually this is in the root of the public_html folder. Seeing this was not effective I have created the php.in file manually inside public_html folder and added the following line.

    max_execution_time = 700

    I ran a managed backup again and the compatibility warning disappeared but still the "Empty REsponse" error was still shown immediately after starting the process. I then enabled debug logging by adding the following lines of code in wp-config.php file of the website in question:

    define('WP_DEBUG', true);
    define("WP_DEBUG_LOG",true);
    define("WP_DEBUG_DISPLAY",false);

    I ran a Managed Backup after it failed with the same error I checked the debug file created in 'wp-content/debug.log" and found that the Snapshot was failing due to a memory limit issue. It was reporting an error like this:

    PHP Fatal Error: Allowed memory limit of XYZ exhausted in snapshot/lib/Snapshot/Helper/Utility.php

    Again, I tried to edit cPanel for the memory limit but it was not effective so I ended up adding the following lines in of code in wp-config.php:

    define("WP_MEMORY_LIMIT","256M");
    define("WP_MAX_MEMORY_LIMIT", "3000M");

    After that I tried to run another Managed Backup and it didn't fail instantly as before it seemed to be working but around 10% it failed with a "404 Not Found" error returned by Nginx.

    It was also took a lot of time to get there so I added the following line of code in wp-config.php which tells Snapshot to attempt using System functions to create the backup instead of using PHP:

    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);

    I started another Managed Backup, even though its still not completed but it didn't seem to have any issues for a very long time, the only issue was that the Support access is time based so if running a long process the support access expires and after that I was unable to see the progress, I had to login again. For me to be able to test this fully I will need a login username and password so I can test without being logged out of support access. I could have created an account because I still can login but I do not to do that without your permission, so please create a new admin account for us or share the current one, you can share via our secure contact form , on the contact form choose "I have a different question" then write as follows:

    Subject: "Att: Lindeni Mahlalela"
    Message:
    - WordPress login details (username and password)
    - Link back to this thread for reference

    Normally, we should be doing all these tests on a staging site but when I tried to access the one you created the Managed Backups feature was not activated and it requires a key that you can get from the Hub so I was not able to test on the staging site because of this. I have also added the settings I mentioned above in your staging site so that once you activate Managed Backups you will be able to test with the same configuration I had on your live site.

    Please test on your side and let us know the results, we will always be happy to help in any way possible. If you have managed backups activated on your staging site then you can share the login details for it instead and we will let you know what changes we made so that you can apply to your live site.

    I hope this helps.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.