Getting error after upgrading buddypress

I noticed that several of the themes were updated for the upgraded buddypress. I am using Blogs MU, not one of the themes updated, and after upgrading buddypress I am getting the following error when trying to delete, spam, or any other function in the site admin "user" area:

Fatal error: Using $this when not in object context in /home/positive/changingme/wp-content/plugins/buddypress/bp-groups/bp-groups-classes.php on line 1053

I am using the same setup on two different sites and this is happening to both. I deactivated all plugins before upgrading buddypress as well.