Getting 'Error establishing a database connection' after trying to enable WP Multisite

I was following the steps of how to enable WP Multisite and after I finished step 6 I got this error:

Error establishing a database connection
This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

Are you sure you have the correct username and password?
Are you sure that you have typed the correct hostname?
Are you sure that the database server is running?
If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

I went back and un-did the changes and am still getting the same message. Any suggestions?

  • tonyaguilar
    • New Recruit

    This is some of the text inside the wp-config.php file. Do I have to put my host username/password in place of the DB_USER & DB_PASSWORD? I apologize for these questions, but I'm a newbie. Thanks for your help.

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'database_name_here');

    /** MySQL database username */
    define('DB_USER', 'username_here');

    /** MySQL database password */
    define('DB_PASSWORD', 'password_here');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

  • Mason
    • DEV MAN’s Sidekick

    Hiya tonyaguilar,

    That's a bit odd as your wp-config.php file is normally populated with the correct information during install. As mentioned above though, you will need to add that information in there from mySQL.

    Let us know how it goes. Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.