getting error in dashboard when trying to update wpmu dev plugins

Hi,
When I'm trying to update the wpmu dev plugins using the dashboard on one of my client sites i'm getting the following error:
The plugin is at the latest version.

It still says it needs to be updated though.