getting error message when downloading Floating Social

I am getting an error message when I try to install the Floating Social plugin from the WPMU dashboard. I had installed it previously, but removed it. Now I want to re-install it.

Am I doing something wrong, or has there been a glitch in downloading? I noticed I got the same message from other plugin downloading attempts.

Thanks, Joe.