Getting error on Checkout

I am getting this error when i want to test the checkout:
"Secure Connection Failed. An error occurred during a connection to madeinusa-shopping.com.( my website). SSL received a record that exceeded the maximum permissible length.(Error code: ssl_error_rx_record_too_long)"

  • Dean Kaus
    • The Bug Hunter

    What payment gateway are you using? I had a similar problem when setting up my marketpress site. I discovered that (I was using paypal) and I was using the API's for PayPal Live but was testing in the sandbox mode. Once I entered in the correct information everything worked properly.

    Hope this is of help to you.

  • caesaregypt
    • WPMU DEV Initiate

    Thank You for your prompt replies.
    @Arun: My host provider is 1and1.com, should I check with them?
    @Dean: I also set up Paypal, and I set Live, entered all the API informations, and it is still giving me error on checkout( tested on all 5 Browser). I will need all kind of payment of course, not just Paypal, but mostly regular CC payments .
    One more question I have since we are talking about MarketPress here:
    My website will be operated as Amazon or Etsy, EBay, etc... Where the producers, sellers will registrate themselves , and sell trough my site, I draw a commission . Will the MarketPress work for this?
    Thank You

  • caesaregypt
    • WPMU DEV Initiate

    I just would like to add one more thing:
    The error message with the SSl is showing up only on Firefox, other Browsers just simple cannot open it!
    So the problem is, that the Checkout on MarketPress is NOT WORKING!
    I set up the products, added price, shipping, setup the API for Paypal Express Checkout, but when someone click on the Checkout, it still doesn't work! What did i forget? There is any special setup?
    (I got the answer from my host provider a couple of minutes ago, by the way, and they said that everything is fain at their end!)

  • aecnu
    • WP Unicorn

    Greetings caesaregypt,

    Something is definitely wrong there and if you only have the PayPal Express gateway enabled the only SSL Certificate that comes in to play is PayPals.

    Please send the uRL where you are getting the SSL error.

    Look forward to trying to help figure this out.

    Cheers, Joe

  • caesaregypt
    • WPMU DEV Initiate

    Hi aecnu,

    Thank You for your help. I did open another topic about this subject before, and we realized that it was the problem with the API things. When I copy-pasted them, there was an extra space in there, thats is why it didn't work.
    Now it is working! At least with the major Credit Cards. I still have issues with the Paypal payments, but the most important that it is working at least with the CC!
    Thanks Again

  • Dean Kaus
    • The Bug Hunter

    Hello @caesaregypt
    I'm willing to bet that your paypal API information isn't entered in correctly. You may have received 2 different sets of API's from PayPal. 1 will only work while your in Sandbox mode (this setting is under store settings, click on the PayPal gateway, then check in the PayPal mode to make sure you are either in Live or Sandbox mode.

    I suggest that you copy your PayPal API credentials into notebook and separate each line so you don't accidentally copy extra spaces or hidden control codes that may not appear but copied if you're copying and pasting from an email.

    Lost importantly (and this is where I went wrong) is making sure that the correct credentials are copied into the correct places. In fact before I past into the store settings area I actually put the cursor in the box I'm going to past the info into, hit Control A to select all in that box and then Control V to paste.

    Let me know if this works for you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.