Getting error when trying to add image to gallery element

When I try to add images to gallery element I get the following errors:

This is a video on how to reproduce the issue

https://monosnap.com/file/8Uzo7YKH1FcdeMmUWmfVi5RqDnm6BG

Plugin conflict didn't do any change.

Access details provided in the internal ticket.

Thanks in advance!

  • Adam Czajczyk
    • Support Gorilla

    Hello Alex

    I hope you’re well today and thank you for your question!

    I checked your site and I’d like you to start with a simple tweak. Please add following line to the “wp-config.php” file of your site, right above the “/* That’s all, stop editing */” line:

    define( 'WP_MEMORY_LIMIT', '256M');

    Once that’s done, check if the issue still happens. If yes, let me know and we’ll investigate it further.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Alex

    Thanks for your response.

    In that case I’ll have to take closer look. Unfortunately, I’m not able to access FTP as it doesn’t allow me to. Using credentials that you shared during the chat it says:

    Response:	530 Login failed: please verify the username and password supplied, and that FTP locking is either disabled or permitted for your current IP address.

    I believe my IP needs to be white-listed then. My current IP is 83.9.44.249 but I don’t know and have no way of knowing when will it change so white-listing it might give me access or not, unfortunately. Is there any other way to access the site install like cPanel (without IP restrictions) or perhaps you could temporary disable that IP restriction entirely?

    Note: please do not post any access credentials here. If you white-list an IP or disable that entire IP lock simply do let me know here. In case you were about to send any additional access credentials please use this form instead

    Contact Us

    and the template below:

    Subject: “Attn: Adam Czajczyk

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    then let me know here once the message is sent.

    Kind regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Alex

    Thank you, I’m afraid though that it didn’t help much. Apparently my IP has changed since then (I’m sorry for the delay). Sometimes it stays the same for weeks but sometimes it changes even a couple times a day – unfortunately I have no control over that process.

    Most of us are using dynamic IPs so I*’m not quite able to pass that over to somebody with “static IP” either. Is there no way to disable that IP blocking entirely for the troubleshooting time?

    if that’s not an option at all, we could try a different way then. It won’t be that useful but would at least give me some partial insight into the site installation. You could install this plugin on the site:

    https://wordpress.org/plugins/file-manager/

    It’s too risky for me to make any changes to any files using it (when I’m not able to access via FTP) but it should let me look in, at least. However, in such case I’d also like you to make sure first that following lines are in the “wp-config.php” file, above the “/* That’s all, stop editing */” one:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Looking forward to your reply,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Alex

    Thank you very much, it worked now!

    The good and kind of bad at the same time news is that I don’t see anything wrong there in terms of configuration. I checked the site itself again but also checked debugging, checked files on server, looked for possible errors in WP log – but to no luck.

    I also checked if Smush or Hummingbird is possibly involved here but to no success either. Yet, there’s still that 500 error and it makes me think that I’m still missing something. These 500 errors are on “admin-ajax.php” calls from media library, but only in page builder. This is strange. There’s nothing “visible via FTP” that could be blocking it too. But I think there are some additional configuration aspects that I/we might not have access to from that point. For example, I noticed that asset optimization configuration behaves a bit unexpectedly: it’s taking slightly too long time and doesn’t return the same resources upon re-check.

    Is there any server-side cache (of any kind) that you could try to clear up and – better yet – temporarily disable? Does you host offer some sort of CDN feature that is currently enabled but could temporarily be disabled? Are there any server-side security tools such such as some sort of firewall or – possibly – some kind of “hardener” that might be causing some “access lockouts” to files/for incoming requests?

    I know it’s a lot of question but if you could check it – so we could just narrow things down, especially that the conflict test conducted during the chat didn’t bring any results.

    Kind regards,

    Adam

    PS. It would be great if you could please keep that IP lock on FTP off for now, until we’re done with the case.

  • Adam Czajczyk
    • Support Gorilla

    Hello Alex

    I hope you’re fine today and I’m sorry for the delay.

    I’ve done some research on the issue meanwhile and there’s something else that’s worth giving a try. If you go to the “WPMU DEV -> Support” page in site’s back-end, click on “System Info” button and switch to “PHP” tab, you’ll find the “post_max_size” line there – note down its current value please.

    Then check if your host allows you to change PHP settings – that can be done via server management panel usually. If there’s no such option, please get in touch with your host and ask them if they could increase that value for you (or tell you how you can do it by yourself on your server) and basically try to set twice as high value for it of what it currently is.

    If that doesn’t help either, I’m afraid that would be related to the page builder and/or theme and I’d recommend getting in touch with it developers, raising support ticket with them as they might actually be familiar of similar issues already and how to solve them.

    Kind regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Alex

    Thank you for letting me know!

    Yes, the fact that there’s so many photos in there does seem to be related but since nothing help so far, including that last change, it suggests that it’s somehow related to the way the page builder (or specifically this “gallery” module) handles adding the images – that’s why I suggested getting in touch with its developers.

    I believe they might be aware of this or similar issues and might have some solution or workaround to try.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.