Getting error when using Custom Press plugin

i have set up a custom post type using custom press and have set it to has archive =true.
i am getting an error: "Warning: Illegal offset type in isset or empty in /home/content/19/8024919/html/wp-includes/post.php on line 840"
on the archive page. the page displays correctly except for the error. i am using a theme "Swagger" from themforest author is themeblvd.

    aecnu

    Greetings scottland2069,

    Welcome to WPMU DEV!

    This certainly sounds like a database warning to me, be certain that it is indeed a warning and not an error as is self evident - and of course should not be there in any event.

    Lets go ahead and go into full blown trouble shooting mode because it appears there may be some conflict here and one way to find out conclusively.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe