Getting Google Analytics MU Working

Hey everyone, I'm setting up my MU network as we speak but have
a question on installing the GA MU plugin correctly. From what I
understand (correct me if I am wrong) I'm able to track Network
Wide all traffic, meaning user's sites as well as letting them track
their own analytics.

With that assumption...

Where, specifically how do I put my "master" tracking in place.
I created a UA for the whole network and put in the UA# within
the primary blog...

Is there anything else?
What about all the trackingcode embed code stuff?
Does the GA MU plugin place all that stuff in there for me?

Thank you in advanced.

  • drmike
    • DEV MAN’s Mascot

    Where, specifically how do I put my "master" tracking in place.

    Should be an option on your Dashboard -> Site/Network Admin -> Options page near the bottom.

    put in the UA# within the primary blog...

    That is incorrect. That UA# goes on the Site/Super Admin -> Options page as noted up above. What you've done is added the code only for the blog in question.

    Does that make sense?

    I was going to point out the use instructions but they don;t come out specifically as say that. Mason, can we get that edited please?

    edit: Any idea what the correct tag for this plugin is now? The old one doesn't work anymore and all the ones that I can think of don;t work either.

  • bamf
    • Design Lord, Child of Thor

    Hey Dr.Mike thanks for the help and I made a video to show
    you that there is no GoogleAnalytics options for SuperAdmin
    in my setup.

    <>

    Now a funny and simple solution came to mind....
    Do I need to also install the Google Analytics Plugin
    from the Wordpress Codex?

    This one?
    http://wordpress.org/extend/plugins/google-analytics-for-wordpress/

    I haven't... I thought the plugin from you guys is that one
    plus whatever MU functions where added.

    But as I look at the name of the one from you guys... it's
    got the words "asyn" in the file name... hummmmm.

    Thanks and let me know what to do next.

  • Mason
    • DEV MAN’s Sidekick

    Hiya bamf,

    Doesn't look the video link worked. You don't need to use the plugin from wordpress.org, just ours is sufficient. I'm not sure why the Analytics field isn't showing up under Super Admin.

    I'll ask Ivan to take a look at this, are you using the most recent version?

    Thanks!

  • Ivan
    • The Incredible Code Injector

    Hi bamf,

    If you are using WordPress 3.0.X. and 3.1.X ( Normal Activate ) Both you and your users can set the "Tracking Codes" and other options inside: [Settings]->[Google Analytics].

    If you are using WordPress 3.1.X ( Network Activate ) the Super Admin sets the settings inside the Network Settings menu. All other users inside their Settings Menu.

    Please follow this thread: https://premium.wpmudev.org/forums/topic/google-analytics-v114 as I am updating any FAQs there frequently.

  • bamf
    • Design Lord, Child of Thor

    Hey guys, took me a few days to get on this post, but up tonight troubleshooting,
    so any help would rock. Still have not figured this out...

    Here is the link missing video from a few post ago:
    http://www.screencast.com/users/justinzimr/folders/Jing/media/b16ad33f-daf3-477a-b6a5-04e09698fee8

    Ivan: I'm running 3.0.4 and Network Activate, is that not compatible with the ability to set the network super admin stats and the single user sites?

    I also posted these comments in the thread link you provided.

  • Marcus
    • Site Builder, Child of Zeus

    i don't get any options in Super Admin > Options.

    in fact, for me I've noticed that logging in as super admin and changing the value in Settings > GA changes it on all sites.

    don't know the effect of a normal user changing the settings, not relevant in my case.

  • nickd32
    • The Incredible Code Injector

    i don't get any options in Super Admin > Options.

    Hi @Marcus,

    Ivan posted the answer to your question here:
    https://premium.wpmudev.org/forums/topic/google-analytics-v114#post-74537

    - Basically, for WP 3.0.4 and earlier, the options only show up in [Settings]->[Google Analytics].
    - For WP 3.1, it will show up under the new [Network Settings] menu

    in fact, for me I've noticed that logging in as super admin and changing the value in Settings > GA changes it on all sites.

    I also noticed this behavior, which is strange. But if you log in as another user (not a super admin), you will get the option to change the UA- code for each sub-blog.

    For some strange reason, if you're logged in as the super admin, it shows you the global network-wide UA- code only in [Settings]->[Google Analytics], regardless of which sub-blog you're on.

    Hopefully, that will be fixed soon.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.