Getting Internal server error when trying to login

http://www.johnsroberts.com/wp-admin/

Hi, the site above is loading fine but when i go to the login page i get...

'Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@johnsroberts.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

What could be causing this?

  • Nastia

    Hello Studio3creative

    I hope you are doing well!

    500 Internal Server it is the most common error that you may get with WordPress and it is easy to resolve.

    First, step is to make sure that the .htacecss file is not corrupt. Access your site files via FTP and rename the .htaccess file to .htaccessdeactivate. Try to access your site again. If the site is working, got to Settings > Permalinks and re-save changes to regenerate a new .htacces file.

    If the above will not help, increase the PHP Memory of your site. Add the following line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '3000M');
    Make sure that you insert this line BEFORE /* That's all, stop editing! Happy blogging. */ in the wp-config.php file. Check if you can login to your site.

    If the error persist, deactivate all plugins by renaming the /plugins/ folder to /plugins.deactivated/ that is located in the /wp-content/ folder. Try to access your site, if you can access it than it is a cnflict with a plugin.

    Once you do that, go back to your /wp-content/ folder and create new “plugins” folder. You can move plugin's folders from the/plugins.deactivated/ into the new /plugins/ folder one by one or in groups to test when the issue occurs again

    At which point, you will know exactly which plugin caused the issue.

    Let me know how it went!

    Kind regards,
    Nastia

  • Nastia

    Hello Studio3creative ,

    I've visited the wp-admin page and it loaded for me. Would you please have a look again and let me know if it is working for you?

    If it is not, please clear the browser's cache and try again. Please see here how:
    http://www.refreshyourcache.com/en/home/

    If again you can't access it please make sure that the host provider hasn't blocked your IP address, this happens sometimes.

    Let me know how it went!

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.