Getting "padding add-on" and "duration add-on" to work properly

hi support team

sorry for having to ask you guys again. thanks to your support i discovered the padding add-on yesterday and already got a major step forward. now i’m down to the last issues.

let me try to explain:

i have one provider with two service durations. the first appointment is 150 minutes, all the other appointments are 120.

my current configuration:

base time: 120 minutes

service 1: 120 minutes + 30 minutes padding after

service 2: 120 minutes no padding

padding resolution: largest

time slot calculus method: minimum time based

boundaries detection: detect overlap

the problem:

despite having minimum time base selected, there are huge gaps in between the appointments. when a 150 minute appointment is booked at 11am, the next customer who wants to book a 120 minute appointment sees 3pm as next option. this way, you lose 90 minutes in between.

what i need:

all i really need, is to be able to have 150 minute and 120 minute appointments without any gaps in between them.

i honestly thought i had it when i was shown the padding add-on, but then i still couldn’t get it done.

could someone tell me, which piece of the puzzle i am obviously missing here?

thanks again for any help guys.